1

After severe difficulties with my graphics card and numerous failed attempts to fix it, I decided to reinstall Ubuntu 16.04 on dual-boot computer.

I had the following partitions:

  • /dev/sda
  • free space 1MB
  • sda1 fat 32 272MB
  • sda 2 134 MB
  • sda3 ntfs 60000MB
  • free space 0MB
  • sda5 biosgrub 1MB
  • sda7 ext 4 49998MB Ubuntu 16.04
  • sda6 swap 9101 MB
  • sda4 ntfs 524MB
  • free space 0MB
  • /dev/sdb
  • sdb1 ntfs 491000MB
  • free space 492085MB
  • sdb5 swap 17118MB
  • /dev/sdc

I reinstalled ubuntu on the same partition - edit partition> Ext4 journaling file system, Format- Y, Mount- /

I loaded the selected the boot loader to be installed on sda hard disk.

After installation and restarting the computer I get the message:


GNU GRUB version 2.02~beta2-36ubuntu3.1

Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions.

grub>


Previously when trying to install I had the same issue, but fixing the partitions made it work. This time I can't seem to get it to work even though the bootloader is installed on the sda disk.

I've tried the following:

  • reallocating partitions, reformatting and rebooting
  • manual reinstall of grub from USB boot: sudo mount /dev/sda7 /mnt, for i in /sys /proc /run/dev; do sudo mount --bind "$i" "/mnt/$i"; done, sudochroot /mnt, update-grub, grub-install /dev/sda, reboot installation seemed to work but on reboot - I get the same black screen
  • booting from grub: grub> set pager=1, grub> ls, #which comes up with (hd0), (hd0,apple2) (hd0,apple1) (hd1) (hd2) and multiple gpt and msdos grub> ls (hd0)/, which comes up with disk/ boot/ casper/ dists/ EFI/ install/ isolinux/ md5sum.txt pics/ pool/ preseed/ README.diskdefine ubuntu
  • tried a different way of reinstalling grub on live USB: sudo mount /dev/sda7 /mnt, sudo mount --bind /dev /mnt/dev && sudo mount --bind /dev/pts /mnt/dev/pts && sudo mount --bind /proc /mnt/proc && sudo mount --bind /sys /mnt/sys

    sudo chroot /mnt

    grub-install /dev/sda grub-install --recheck /dev/sda update-grub

I get the message /proc/devices not found: fopen failed: no such file or directory

  • tried boot repair, disabling secure boot in the BIOS, dpkg configure, apt-get install -fy, apt-get purge -y --force -yes grub*-common grub-common:i386 shim-signed linux-signed* (on both /mnt and sda7)

I'm not really sure what else to try.

Any help would be extremely appreciated!

Lisa

  • Details of the boot repair:paste2.org/U9nJ3HA8 – L Marfell Aug 30 '16 at 12:14
  • paste2.org/m51f3Mcp – L Marfell Aug 30 '16 at 13:26
  • Your sda is gpt, but sdb is MBR(msdos). Windows only boots from gpt with UEFI, not BIOS. But your ESP - efi system partition which looks like it might be sda1 is not showing any .efi bootable files. And you have grub installed in MBR and a bios_grub partition for BIOS boot of Ubuntu on gpt partitioned drive. Your UEFI also showed UEFI boot entries for both Windows & Ubuntu so you were at one time configured for UEFI boot. Best to stay with UEFI boot and gpt partitioning. And it looks like you left Windows fast start up or always on hibernation. You may need Windows repairs. – oldfred Aug 30 '16 at 13:32
  • @oldfred thank you, boot repair seemed to work in UEFI mode and GRUB is finally working again. Been seeing the black screen since Thursday! So it's such a relief. Thanks for your help :) – L Marfell Aug 30 '16 at 14:39

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.