I am running Ubuntu 16.04 in 16 GB USB drive. I am a newbie in the ubuntu world. I am trying to create a USB disk with 12 GB persistence storage. So that I can use it for the development purposes.

I have created this USB drive using unetbootin. I have selected 100 MB persistence while creating the disk, because I wanted to switch to casper-rw ext2 partition which I created and having 12 GB space. But, even after restarting and booting to windows and live-ubuntu more than 20 times with different settings and juggling between different tools, still unable to get that partition working.

I have tried rufus, unetbootin, and linuxpendrive tools for making persistent file storage system. But to enable partition, I have failed all the time. If I change the txt.cfg file from my windows, it ends up in Busybox dead screen without any error.

First, I partitioned my usb storage to 2 drives from windows 10 using EaseUS Partition Manager. 1 fat32 of 2 GB and 1 ext2 with casper-rw label. Then Installed ubuntu using unetbootin with persistance settings to 100 MB. It works but doesn't use partition for persistence. When I check from the command: df . -h , it says I have /cow with 100 MB space. I tried to delete the file casper-rw from USB drive from fat32 partition from Windows and again booted from USB. But, it fails to boot and stuck to BusyBox Screen.

One article I followed: https://askubuntu.com/a/438734/588390

I tried:

  • As rufus doesn't provide direct option to enable persistence, I tried enabling it with linuxpendrive's Casper-RW creator tool (http://www.pendrivelinux.com/casper-rw-creator-make-a-persistent-file-from-windows/). Then deleted and/or renamed casper-rw file in the root usb. But didn't worked.

  • Tried editing txt.cfg file and it ended up in dead Busybox screen with all the 3 tools.

  • I also tried editing one cfg file inside boot/grub but also ended up in the Black Busybox dead screen.

What's going wrong?


  • You said " I have selected 100 MB persistence while creating the disk, because I wanted to switch to casper-rw ext2 partition which I created and having 12 GB space. " What is the difference between this 100 MB persistence and your 12GB casper-rw file? – Anwar Aug 30 '16 at 7:59
  • Because, It was mentioned in many articles that first create with casper-rw file and then delete that file so it will use the casper-rw partition – kirtan403 Aug 30 '16 at 8:31
  • You need to repoint your boot-loader menu (grub) to the new partition. (this is the advice that is generally not pointed out on casper-partition answers!) I managed to get this working recently with a Lubuntu 14.04 custom iso as described here (http://askubuntu.com/a/878009/544376). that's my answer to someone else's question where he was having a similar issue. My answer used other answers on that 'thread', so be sure to read the entire thread before you try again. Good luck! – JamesBB Feb 2 '17 at 17:00

You can use mkusb to create persistent live drive. It creates a partition for persistence by default and automatically. The picture shows the steps in the wizard interface to create a persistent live system with mkusb version 12 alias dus.

enter image description here

See the following links for more details,

How do I make a persistent live USB of Ubuntu 16.04?




Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.