0

I have been trying to install 16.04 to a friend's Macbook Pro (7,1) with the intention of dual booting.

I was following these instructions (https://help.ubuntu.com/community/MactelSupportTeam/AppleIntelInstallation). I installed ReFIT, made a live USB and partitioned successfully using Disk Utility. However I made an error (under 'Start Installing'): I installed the systems side by side instead of manually allocating the partitions so that grub would be installed to my root partition.

Now when i open Gparted in the live CD i get a Libparted error: "The primary GPT table is corrupt, but the backup appears OK, so that will be used"

If i click OK, i see that i have a 200MiB EFI system partition at the start of the drive.

Based on responses to this question, i will open up a new question trying to solve this problem.

Regarding the Ubuntu installation, i worked out that rEFIt was no longer supported, to i uninstalled that and installed rEFInd.

Now when i boot the machine I get to the rEFInd screen, I see 3 large logos, above 5 smaller logos. The First large logo: Ubuntu logo, on the hard disk, described as: “Boot EFI\ubuntu\grub64.efi from EFI” The Second large logo: OSX logo, on the hard disk, described as: “Boot Mac OSX from Macintosh HD” The Third large logo: Ubuntu logo, on the hard disk, described: “Boot boot\vmlinnuz-4.4.0.36-generic.efi.signed from 10GiB ext4 volume” First small logo: a key, described as: “Start MOK utility at EFI\ubuntu\MokManager.efi on EFI Second small logo: About rEFInd Third small logo: Shutdown computer Fourth small logo: Reboot computer Fifth small logo: Start firmware update utility at EFI\ubuntu\fwupx64.efi on EFI

Clicking the first large logo boots the GRUB menu. The screen then takes on the purple hue of an Ubuntu launch before the screen blinks ad goes black. I have to hard reset to get the machine back Clicking the second large logo successfully boots OSX Clicking the third large logo posts a whole lot of text to the screen, before the screen blinks and goes black. I have to hard reset to get the machine back If I hold down ‘alt’ key at start up I only get the option to boot to the Mac partition, clicking this launches OXS.

I have tried running the boot info script mentioned in the answer below, but in mac when i try to launch the unzipped tarball 'bootinfoscript' (using sudo) i get: 'sudo: command not found'. Am I meant to be running this script from the live instance of ubuntu?

Thanks for the help on this, sorry if i am not keeping up with something straighforward.

  • If it mentions refit, it is really old. refind is a fork of refit and has been available for years. rodsbooks.com/efi-bootloaders Alternative efi boot loader for UEFI limited systems: rodsbooks.com/refind Best to use UEFI, not BIOS and if it adds a bios_grub partition that is a BIOS boot install. askubuntu.com/questions/732611/… – oldfred Aug 30 '16 at 0:52
  • Thanks for this. I uninstalled rEFIT and installed rEFInd. Then i booted to to live instance of ubuntu and reinstalled 16.04 (created EFI partition). At that point when i started the machine, GRUB started. If i select Ubuntu things launch fine, but launching OSX would fail. I went back into OSX (holding option key), and reinstalled rEFInd. Now rEFInd starts, and i can launch OSX, but launching Ubuntu fails. So i can't get into Ubuntu at all (option key loads OSX). I tried to bless rEFInd from OSX, but that made no difference. Any ideas on how to fix this so ubutntu launches from rEFInd? – MorrisseyJ Aug 30 '16 at 3:21
0

First, the GParted message about the primary GPT data being corrupt but the backup being OK means that there's a SERIOUS problem with your partition table. FIX IT IMMEDIATELY!!!! If you don't know how to do this, consult my page on the subject and/or post another question. (You'll need to provide details, like the output of gdisk's p and v commands, if you expect any real help.) Continuing to use a computer with a damaged partition table more-or-less guarantees that you'll have serious trouble sooner or later -- and in this context, "serious trouble" could mean a complete loss of all the data on your computer! Note, however, that attempts to repair damaged partition tables can sometimes lead to even worse problems, so don't go mucking about randomly. Back up the whole disk and, if you don't know what you're doing, ask for help!

Second, now that you've installed rEFInd, you should be able to boot either OS X or Ubuntu from rEFInd. Since Ubuntu isn't launching, there's obviously a problem, but you've provided insufficient details for a proper diagnosis. Please run the Boot Info Script. This will generate a file called RESULTS.txt. Post that file to a pastebin site and post the URL to your document here. This will give us more details about your configuration, which may help with the diagnosis. Also, please describe what icon and description is associated with the Ubuntu/Linux option in rEFInd, and describe what happens when you try to launch it. If there are multiple Ubuntu or Linux options in rEFInd, try them all, and describe what happens for each one when it fails.

I recommend you add a comment to this answer and edit your original question to provide the new information.

EDIT:

It sounds like your Ubuntu boot problems are related to video drivers. There are numerous questions and answers on this site about "black screen" problems when booting Ubuntu, particularly in EFI mode. I recommend you search for them. You can probably overcome the issue by adding an appropriate keyword or two to the kernel's options, but what option will work depends on your hardware. In rEFInd, you can add options by hitting F2 or Insert twice, rather than Enter, when launching the boot/vmlinuz-* entry. If you find kernel options that work, you can then add them to the /boot/refind_linux.conf file to make them permanent. (If that file doesn't exist, the mkrlconf script that comes with rEFInd will create it, but you must run that script via sudo.)

  • Thanks very much for this. Sorry about the slow reply, i have been juggling work. I will ask a new question regarding the GParted message, but don't have a backup disk on me at the moment.I have updated the original question as best i can. Thanks again for the help on this. – MorrisseyJ Sep 4 '16 at 17:05
  • Please see my edit, above. – Rod Smith Sep 5 '16 at 12:58
0

So i have finally found an afternoon to look at this. In the end it was all every easy to solve. As per Rod's suggestion the problem was with the video driver. This version of the macbook (7.1) uses the Nvidia 320m video card, and the forums were populated with people noting that the proprietary driver as causing problems for them. I forgot that after i was initially booting to ubuntu i was installing the proprietary Nvidia driver, when i was installing the broadcom driver, which i needed to get wifi.

Installing that proprietary driver was causing the problem. I should have been paying attention.

Since i had nothing on the install yet, i just did a reinstall and this did not install the proprietary driver. Now everything boots fine.

Thanks very much, Rod Smith, for you help. I really appreciate your time.

I have taken up the GPT partition problem in a new thread. The only time it seems to generate errors is when i run gparted from a live usb. Question is here: corrupt primary partition, no problem in gdisk

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.