16

After updating ubuntu from 14.04 to 16.04 I've experience this weird behavior. When I press Alt+Tab, two interfaces show up, the one from unity (the same that showed up when I was using the 14.04), and another that i don't have an idea from where it came from... LOL (no I didn't read the changelog, sorry for that XD ).

Thanks in advance.

  • Not sure what you are asking. Quick Alt + Tab switches me between two most recent windows. Long press Alt + Tab lets me cycle between parent windows, picking on lets me pick on their children windows. It's always been this way I think since 14.04 when I joined up. – WinEunuuchs2Unix Aug 29 '16 at 23:14
  • 1
    thats what I mean, link. you see how there is two "interfaces" to the alt+tab cycling? hope you do. Like, there is the bottom one which cycles through all windows (including minimized) and there is the front one that cylces through only the open ones <- want to get rid of this last one – vhoyer Aug 30 '16 at 1:17
  • Yes I see the two interfaces. But when testing your question I found a third interface where it would cycle through five open children of a parent which would be much worse for you I imagine. I don't use Alt+Tab at home under Ubuntu because I have so many open windows and two screens I just click on what I want and make sure parts of windows are sticking out and clickable. At work I use Alt+Tab to switch between two apps under Windows but work computers are simpler than home :D. Anyway the screen snapshot you've linked to has always been that way for me. Short press Tab key vs. long press Tab. – WinEunuuchs2Unix Aug 30 '16 at 1:23
  • you sure there is no way of fixing it? I like my alt+tab ;-; (i mean, there is always a way when it comes to linux, but, something a beginner can do. hehe) – vhoyer Aug 30 '16 at 1:27
  • Just press Alt-Tab quickly and not like a drunken sailor it should work fine. – WinEunuuchs2Unix Aug 30 '16 at 1:31
31

I've been seeing the same thing on one system, and it's a bit annoying. I finally accidentally stumbled upon the answer for my case:

It was the Compiz switcher also capturing the ALT - TAB key combo along with the Unity switcher.

It can be disabled by installing the CompizConfig Settings Manager:

sudo apt-get install compizconfig-settings-manager

I ran it by clicking on the Search icon and typing:

CompizConfig

Then click on the icon.

Click on Window Manager → Application Switcher and disable the Next Window key.

Hope this helps you too.

  • In my case, I had a conflict for Alt-Tab, two binding were using it: Next window in the plugin Application switcher and Lower window in the plugin General Options – galath Mar 5 '18 at 11:47
  • You can also just uncheck the checkbox for "Window Manager > Application Switcher" instead of disabling multiple keybindings as well. – wisbucky Jul 2 '18 at 21:05
  • Man, Thanks a ton :)) – Abdelrahman Elkady Jun 30 at 23:04
1

or call also CompizConfig Settings Manager via Terminal:

1.

sudo apt install compizconfig-settings-manager
  1. Open the CompizConfig Settings Manager by typing:

    ccsm

  2. Select "Window Management"

  3. Uncheck "Application Switcher"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.