7

EDIT Aug, 2017: The problem does not occur with the new intel graphics driver integrated in the linux kernel ( dont know the version ), that is integrated in 16.04. I had this problem multiple times with 14.04.

This ( unreadable contents on the X-session ) hapenned to me the second time and I had to kill the X-session to restore a normal X Session. So, perhaps, it would be interesting for me to just know, what actually hapenned here. Please see the two screen shots.

My current configuration is

X-window-mananger: metacity 2.34.13
Desktop Environment: GNOME Shell 3.10.4
Desktop Manager: lightdm 1.10.6

Let me know, if any other details are required to analyse the problem.

Nautilus:

unreadable-content-nautilus-1

Thunderbird:

unreadable-content-thunderbird-2

  • Don't have a solution, but I've seen this issue on Fedora23/Gnome3.18 (xorg) a few times as well. My impression was it never happened out of the blue, just when the laptop came out of suspend. – bgse Aug 29 '16 at 19:49
  • can you reproduce the problem? – Zanna Aug 29 '16 at 19:54
  • @Zanna In case you are asking me, unfortunately not, the laptop in question is running Ubuntu by now. I could get the exact hardware configuration though, and with a bit of work one could probably deduce the drivers and such that were in use. – bgse Aug 29 '16 at 19:58
  • No, I cannot reproduce the problem. But, I can tell you the steps that happenned. Firefox was using a lot of memory, because of some java script running painlessly. The screen by that time was almost frozen. So, I changed to tty1, killed firefox out of frustration and also evolution ( that I never started myself, but saw in the list of processes ) . After coming back to xsession, I saw this problem. However, I do not want a solution here, but out of sheer curiousity, want speculative answers, what could have happenned here. – infoclogged Aug 29 '16 at 20:51
  • Related (unanswered) question – Zanna Aug 30 '16 at 7:53
8

I have the same problem for about a year and could not find a permanent solution. There is a simple, temporary solution: If you change the "Antialiasing" option of the Fonts to "None", the characters will re-appear. You can use (Unity) Tweak Tool to do so. The next time you log in, you can switch "Antialiasing" to RGBA or Grayscale until you have the same problem.

  • it was good, that I posted this problem here, because I saw the error agin and this time I did not have to kill the Xsession. Thanks to your solution. However, I used Grayscale antialiasing option and it works too. The RGBA option is indeed the cuplrit. Since there is no optical difference between GRayscale and RGBA for me, I would leave Grayscale permanently. – infoclogged Sep 3 '16 at 6:36
  • 1
    Moreover, I found out, that the problem is only with Nautlius. Dolphin shows the fonts even when Nautilus and PCManFM fails to show. So, it is definetly a GNOME issue and not any OS kernel driver. – infoclogged Sep 3 '16 at 7:35
  • You may get the same problem with the Grayscale option, too. In such a case, just change anything on the Fonts tab, or switch back to "Restore defaults". – Erol Sep 6 '16 at 19:46
  • This used to help but with latest intel driver doesn't anymore. – abergmeier Dec 2 '17 at 11:13
  • Thanks! Changed to 'Grayscale' and the problem was fixed! – madhat1 Jan 3 '18 at 9:34
0

From the command-line a temporary fix is: xfconf-query -c xsettings -p /Xft/Antialias -s 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.