1

I have made a mistake sideloading Ubuntu on a Windows 10 laptop, a mistake it seems no one else was silly enough to make.

I installed Ubuntu on my machine (Samsung ultrabook series 9) following all the steps, and everything worked perfectly.

I then went to restart, and have the options to start Ubuntu as well as Windows Boot Loader. However when I choose to boot Windows it says the image cannot be found.

When I load the BIOS, I can change my boot priority, and when I put Windows Boot Loader above Ubuntu, the computer resets, and starts Windows. (vise versa for starting up ubuntu).

While this works for now, it seems wrong to have to load the BIOS everytime, why can Ubunto not just load the Windows Boot Loader from the options when I restart?

Thanks!

  • Fast Boot needs to be disabled because it can prevent Ubuntu from booting. Unfortunately, it creates the opposite case from yours, where Windows boots and Ubuntu doesn't show up. You may want rephrase your question, sine Fast Boot is likely not the culprit. If anything, I recommend trying Super User, since it seems like Windows broke. – TheWanderer Aug 29 '16 at 17:43
  • 1
    What exactly makes you think fastboot is the issue? Rather than just restoring the windows bootloader? – Mark Kirby Aug 29 '16 at 17:45
  • Hey guys, thanks for the responses. This is my first time using Ubuntu (or Linux), and very unfamiliar with all of this stuff, so apologies if I'm not too clear. I have just managed to start Windows by changing the boot priority and setting Windows Boot Loader above Ubuntu. If I do that, Windows boots perfectly. However I found this in the BIOS settings, and in order to start Ubuntu I have to go into the BIOS and change the priority again. This solves it for now and means I didn't lose everything (phew). What do you mean by restoring windows bootloader? Is there a way to fix this? – Ryan Saffer Aug 29 '16 at 17:50
  • Have you tried running this? help.ubuntu.com/community/Boot-Repair It can fix lots of boot issues. Looks like the bootloader is there, now you are in Windows, you can disable the fastboot, right? – Mark Kirby Aug 29 '16 at 17:58
  • 1
    Hi Mark, You were right about fastboot - not the issue. However I solved it!! On another thread someone mentioned disabling 'Secure Boot' in the BIOS, which I did - and everything working perfectly!! Thanks for your help, I will close the question. – Ryan Saffer Aug 29 '16 at 18:03
1

SOLVED

It seems the issue wasn't too hard to solve, but in case someone else stumbles across this I'll leave it here.

In my BIOS settings I disabled 'Secure Boot'.

More details here: https://askubuntu.com/a/676106/588173

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.