3

My environments.yaml looks like this:

environments:
  test:
    type: local
    control-bucket: juju-a14dfae3830142d9ac23c499395c2785999
    admin-secret: 6608267bbd6b447b8c90934167b2a294999
    default-series: oneiric
    juju-origin: distro
    data-dir: /home/bruno/projects/juju

juju bootstrap runs perfect:

2011-11-22 19:19:31,999 INFO Bootstrapping environment 'test' (type: local)...
2011-11-22 19:19:32,004 INFO Checking for required packages...
2011-11-22 19:19:33,584 INFO Starting networking...
2011-11-22 19:19:34,058 INFO Starting zookeeper...
2011-11-22 19:19:34,283 INFO Starting storage server...
2011-11-22 19:19:40,051 INFO Initializing zookeeper hierarchy
2011-11-22 19:19:40,247 INFO Starting machine agent (origin: distro)... 
[sudo] password for bruno: 
2011-11-22 19:23:16,054 INFO Environment bootstrapped
2011-11-22 19:23:16,079 INFO 'bootstrap' command finished successfully

Deploy from a known good charm is accepted (tried it with one that I am trying to create):

juju deploy --repository=/home/bruno/projects/charms_repo/ local:teamspeak
2011-11-22 19:28:49,929 INFO Charm deployed as service: 'teamspeak'
2011-11-22 19:28:49,962 INFO 'deploy' command finished successfully

After this I can see that juju debug-log shows activity and I can see the network indicator going on and off and activity on my hard-disk.

Wait...

Looking at juju status I get:

services:
  teamspeak:
    charm: local:oneiric/teamspeak-1
    relations: {}
    units:
      teamspeak/0:
        machine: 0
        public-address: 192.168.122.226
        relations: {}
        state: start_error

juju debug-log does not help and I have no files under /var/log/juju or /var/lib/juju.

Last juju debug-log only shows this:

2011-11-22 19:45:20,790 Machine:0: juju.agents.machine DEBUG: Units changed old:set(['wordpress/0']) new:set(['wordpress/0', 'teamspeak/0'])
2011-11-22 19:45:20,823 Machine:0: juju.agents.machine DEBUG: Starting service unit: teamspeak/0 ...
2011-11-22 19:45:21,137 Machine:0: juju.agents.machine DEBUG: Downloading charm local:oneiric/teamspeak-1 to /home/bruno/projects/juju/bruno-test/charms
2011-11-22 19:45:22,115 Machine:0: juju.agents.machine DEBUG: Starting service unit teamspeak/0
2011-11-22 19:45:22,133 Machine:0: unit.deploy INFO: Creating container teamspeak-0...
2011-11-22 19:47:04,586 Machine:0: unit.deploy INFO: Container created for teamspeak/0
2011-11-22 19:47:04,781 Machine:0: unit.deploy DEBUG: Charm extracted into container
2011-11-22 19:47:04,801 Machine:0: unit.deploy DEBUG: Starting container...
2011-11-22 19:47:07,086 Machine:0: unit.deploy INFO: Started container for teamspeak/0
2011-11-22 19:47:07,107 Machine:0: juju.agents.machine INFO: Started service unit teamspeak/0

How can I troubleshot what is happening here?

2
  • That happened to me too. I simply destroyed the Juju environment and started it up again - and the problem went away. Nov 22, 2011 at 19:44
  • tried that at least 3 times :S Nov 22, 2011 at 19:50

1 Answer 1

7

That looks like its an error in your start hook. The logs for the unit are symlinked from the lxc container into the data dir: {data-dir}/units/{unit-name}/unit.log

Their also in the unit's container at /var/log/juju/{unit-name}.log

For non start/install hooks you can also use the juju debug-hooks command to get an interactive debug shell that acts in the place of a unit's hook.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .