7

I'm having weird issues after an upgrade from 14.04.5 to 16.04.1.

Here is what I get from sudo apt-get update:

Hit http://archive.ubuntu.com xenial InRelease
Get:1 http://archive.ubuntu.com xenial-updates InRelease [95.7 kB]
Get:2 http://archive.ubuntu.com xenial-security InRelease [94.5 kB]
Get:3 http://repo.percona.com xenial InRelease [15.3 kB]
Hit http://archive.ubuntu.com xenial/main amd64 Packages
Hit http://archive.ubuntu.com xenial/universe amd64 Packages
Hit http://archive.ubuntu.com xenial/main Translation-en
Hit http://archive.ubuntu.com xenial/universe Translation-en
Get:4 http://archive.ubuntu.com xenial-updates/main amd64 Packages [383 kB]
Get:5 http://archive.ubuntu.com xenial-updates/universe amd64 Packages [324 kB]
Get:6 http://archive.ubuntu.com xenial-updates/main Translation-en [145 kB]
Get:7 http://archive.ubuntu.com xenial-updates/universe Translation-en [111 kB]
Get:8 http://archive.ubuntu.com xenial-security/main amd64 Packages [138 kB]
Hit http://repo.percona.com xenial/main Sources
Get:9 http://archive.ubuntu.com xenial-security/universe amd64 Packages [41.5 kB]
Get:10 http://archive.ubuntu.com xenial-security/main Translation-en [57.0 kB]
Get:11 http://archive.ubuntu.com xenial-security/universe Translation-en [25.1 kB]
Get:12 http://repo.percona.com xenial/main amd64 Packages [16.9 kB]
Hit https://apt.dockerproject.org ubuntu-xenial InRelease
Hit https://apt.dockerproject.org ubuntu-xenial/main amd64 Packages
Get:13 https://download.serverpilot.io xenial InRelease
Ign http://repo.percona.com xenial/main Translation-en_US
Get:14 https://apt.dockerproject.org ubuntu-xenial/main Translation-en_US
Get:15 https://download.serverpilot.io xenial/main amd64 Packages
Ign http://repo.percona.com xenial/main Translation-en
Get:16 https://download.serverpilot.io xenial/main Translation-en_US
Ign https://apt.dockerproject.org ubuntu-xenial/main Translation-en_US
Ign https://apt.dockerproject.org ubuntu-xenial/main Translation-en
Hit https://packages.gitlab.com xenial InRelease
Ign https://download.serverpilot.io xenial/main Translation-en_US
Ign https://download.serverpilot.io xenial/main Translation-en
Hit https://packages.gitlab.com xenial/main Sources
Hit https://packages.gitlab.com xenial/main amd64 Packages
Get:17 https://packages.gitlab.com xenial/main Translation-en_US
Ign https://packages.gitlab.com xenial/main Translation-en_US
Ign https://packages.gitlab.com xenial/main Translation-en
Fetched 1,453 kB in 4s (341 kB/s)
Reading package lists... Done
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: Unknown Multi-Arch type 'no' for package 'libxapian-dev'
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: Unknown Multi-Arch type 'no' for package 'kwin'
W: Unknown Multi-Arch type 'no' for package 'kwin-dev'
W: Unknown Multi-Arch type 'no' for package 'kwin-wayland'
W: Unknown Multi-Arch type 'no' for package 'kwin-x11'
W: Unknown Multi-Arch type 'no' for package 'libkf5sysguard-dev'
W: Ignoring Provides line with DepCompareOp for package php-psr-http-message-implementation
W: Ignoring Provides line with DepCompareOp for package php-psr-log-implementation
W: Ignoring Provides line with DepCompareOp for package php-seclib
W: Ignoring Provides line with DepCompareOp for package php-sabre-http
W: Ignoring Provides line with DepCompareOp for package php-math-biginteger
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: Ignoring Provides line with DepCompareOp for package php-math-biginteger
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: You may want to run apt-get update to correct these problems

Here is what I get from sudo apt-get autoremove:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libc-dev-bin : Depends: libc6 (< 2.20) but 2.23-0ubuntu3 is installed
                Recommends: manpages-dev but it is not installed
 libc6-dev : Depends: libc6 (= 2.19-0ubuntu6.9) but 2.23-0ubuntu3 is installed
E: Unmet dependencies. Try using -f.

Here is what I get from sudo apt-get -f install

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libarchive-extract-perl liblog-message-simple-perl libmodule-pluggable-perl
  libmysqlclient18 libpam-systemd libpod-latex-perl libsystemd-login0
  libterm-ui-perl libtext-soundex-perl
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libc-dev-bin libc6-dev manpages
Suggested packages:
  glibc-doc
Recommended packages:
  manpages-dev
The following NEW packages will be installed:
  manpages
The following packages will be upgraded:
  libc-dev-bin libc6-dev
2 upgraded, 1 newly installed, 0 to remove and 392 not upgraded.
8 not fully installed or removed.
Need to get 0 B/3,240 kB of archives.
After this operation, 2,457 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/^(.*?)(\\)?\${ <-- HERE ([^{}]+)}(.*)$/ at /usr/share/perl5/Debconf/Question.pm line 72.
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\${ <-- HERE ([^}]+)}/ at /usr/share/perl5/Debconf/Config.pm line 30.
Setting up util-linux (2.27.1-6ubuntu3.1) ...
insserv: warning: script 'K01startencryptd' missing LSB tags and overrides
insserv: warning: script 'S100startencryptd' missing LSB tags and overrides
insserv: Service mountdevsubfs has to be enabled to start service hwclock
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package util-linux (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 util-linux
E: Sub-process /usr/bin/dpkg returned an error code (1)

Please tell me what is going on and how to fix it. As I said from the beginning of the post, it upgraded to 16.04 successfully. Here is the output of lsb_release -a:

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.1 LTS
Release:        16.04
Codename:       xenial

Here is the content of /etc/apt/sources.list:

deb http://archive.ubuntu.com/ubuntu xenial main universe
deb http://archive.ubuntu.com/ubuntu xenial-updates main universe
deb http://archive.ubuntu.com/ubuntu xenial-security main universe

NOTE: As far as my understanding and after my investigation. My repositories aren't causes to this problem. WHY? Check the comment below, from 10k reputation user.

  • you can start with this article usually lots of this issues would happen when upgrading from previous version of OS to a newer because lots of packages from previous version are incompetible with newer OS version that might lead to various conflicts and it's better to disable manually added repositories when doing distro upgrade. – JoKeR Sep 9 '16 at 2:56
  • Looks like the Apt sources might not have been updated correctly during the release upgrade. Could you please include the full output of sudo apt-get update (either directly or as a link to a pastie) in your question? The content of /etc/apt/sources.list might help too. Thanks. – David Foerster Sep 10 '16 at 19:36
  • @DavidFoerster : I've update the question. Please check, thank you. – Toan Nguyen Sep 12 '16 at 8:45
  • 1
    Some fundamental packages util-linux and the Debian package manager seem to be broken in one way or another. I recommend that you download the relevant binary packages built from the source packages glibc, util-linux and dpkg and install them manually with dpkg -i. – David Foerster Sep 12 '16 at 19:22
4
+25

it looks like you have a lot third party repositories enabled and one of them has some broken packages in it, its quite likely that will be fixed in a few hours or days.

If you want to fix it now go in to /etc/apt/sources.list.d and comment the extra repositories out. This should get you back to the point there apt-get update works again.

When that has completed do an apt-get upgrade and then re-add the repositories one by one until the breakage comes back and you will know where its come from. Then you can report the bug to the repo maintainer and re-enable when its fixed.

  • 1
    I've upgrade another server from 14.04 to 16.04 successfully with same repositories. – Toan Nguyen Sep 13 '16 at 3:29
  • dont forget that repo's are moving targets and could well have changed since you did the other server. I haven't seen this problem in the main 16.04 repos – Amias Sep 13 '16 at 10:19
  • Please check the comment of David under my question. Do you think that can solve my problem? Because I don't think the problem came from repo. – Toan Nguyen Sep 14 '16 at 0:45
  • honestly I don't understand why people keep upvoting this... – Toan Nguyen Sep 16 '16 at 2:01
  • i saw Davids comment , look at the packages he links to , go to their bug reports section , they are either old ubuntus or i386. Its possible you might hit some of them if your system was upgraded to 14.04 from previous releases but very unlikely. – Amias Sep 16 '16 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.