0

Background

I was running Ubuntu 14.04 LTS and the software center had been nagging to update to 16.04. Today clicked on the [Update] button in the Software Center.

Current state

Reboot proceeds until

     Starting Show Plymouth Boot Screen

then multiple blank lines and

[ OK ] Started Make remote CUPS printers available locally.

I can <Super> F1 to login on tty1. I see

New release '16.04.1 LTS' available.
Run 'do-release-upgrade' to upgrade to it.

Since the upgrade does not appear to have been successful I'm reluctant to try it without advice.
I tried do-release-upgrade. It said No new release found.

Running lsb_release -a gives

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.1 LTS
Release: 16.04
Codename: xenial

I tried startx and it appeared to start. I stopped it by sudo stop lightdm.

If I try sudo service lightdm start the screen alternately displays a mouse pointer and then the text boot screen, for about 5 seconds.

Edit

I tried sudo apt-get update and got errors such as

Err:1 http://security.ubuntu.com/xenial-security InRelease
Temporary failure resolving security.ubuntu.com

Looks like I don't have network support - ping localhost gets ping: icmp open socket: Operation not permitted

Question

Assuming that the upgrade has not completed, what should I do next to get to a system that boots to the GUI?

Alternatively, is it possible to back out of the update? I still have my 14.4 DVD.

0

So my solution was to revert to the previous version.

I booted from my original "Ubuntu 14.04.3 desktop amd64" DVD, and

  • At the welcome screen, clicked the "Try Ubuntu" button and made sure my most recent backup was current.
  • Rebooted again, then at the welcome screen clicked "Install Ubuntu".
  • At the "Preparing to install Ubuntu" screen clicked continue.
  • At the "Installation type" screen, there are four options. I clicked the bottom one "Something else".
  • A partition map is then shown, including check boxes that determine which partition is to be over-written. Firstly, I have to admit my notes here are sketchy. I have to say I found this screen quite confusing. Since I wanted to retain my data, I was very careful to avoid the checkboxes in the "Format?" column. The feedback on this screen is poor; it kept telling me to do things to the partition map. Since there is nothing labelled "Partition map" it took me a while to work that this screen is it.
  • Eventually I selected my ext4 partition. /dev/sda as the device for the boot loader, and clicked "Install Now".
  • According to How to re-install Ubuntu keeping your data and settings there are three prompts that it's important to get right if you want to have easy access to your old data. These are
  • Your full name.
  • Your user name.
  • Your machine name.

Few notes

  • I didn't test what happens if the full name or machine name are different, but obviously the user name needs to be right. I would expect that an incorrect username would be fixable, with work.

  • When you have to select the filesystem, select "Ext4 journaling filesystem". All the documentation seems to just call it Ext4 without mentioning the journaling part.

And then

Having got a working 14.04 system, I had no Wifi or DVD support. I Googled and messed about for days. All sorts of posts in various places suggest building your own, with all that would entail in the future. Eventually, I tried the "Advanced boot options" in the Grub menu.

I selected the previous kernel, and viola everything works!

Hope that helps someone else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.