4

I haven't found the right setting for Chinese input, IBus pinyin. If I want to write "ni hao" the correct alternative shows up after writing "nih" (as second alternative). But if I continue writing "niha" or "nihao" it will show something like "你哈". It seems it does not accept more than two characters per syllable?

I am used to writing the complete pinyin and not checking after every stroke if the correct alternative is in the list. Can I make it work like that?

I tried the incomplete pinyin switch, but that was not it. (The input method can not be documented, it will not show up on screenshots.)

Thanks

Edit 31/8 The problem was a little different than I first thought, so I changed the question title. Old title: Chinese input: IBus pinyin will not accept all letters in syllable

  • Have you tried fcitx pinyin? fcitx should have better supports for chinese input methods. – Casper Aug 30 '16 at 15:32
  • Thanks. I just looked at fcitx. The first steps of the installation worked fine. But I do not have enough knowledge to fully understand what is happening in step 3 and following. Right now I do a project and I can not risk any malfunction. So I wait a little before I finish this installation. – ycc_swe Aug 30 '16 at 23:50
  • fcitx should be defaultly installed in Ubuntu 16.04, you just need to switch from ibus to fcitx in Language Support and relogin your account. Then, you will find a little keyboard icon at the right-hand side of your top bar. – Casper Aug 31 '16 at 2:02
  • You can also try this and this. – Casper Aug 31 '16 at 2:13
  • The exact steps for switching to fcitx vary between different desktop environments. For Ubuntu with Unity there is an applicable spot in the official documentation. – Gunnar Hjalmarsson Aug 31 '16 at 2:37
4

fcitx should have better supports for all Chinese input methods.

  1. Switch the input system to fcitx in Language Support. (If you don't know what is "Language Support", just search it on the dash.)

    enter image description here

  2. Download the latest Sogou PinYin fcitx plugin from this.

    enter image description here

  3. Double click to launch Ubuntu Software to install the deb installation pack.

  4. Relogin your account.

  5. Try to switch to sogou pinyin input method under the fcitx input method list in the right-hand side of the top bar.

    enter image description here

  6. Type nih or nihao.

    enter image description here enter image description here

  • Thanks for all information in thread. It was obviously more than just a setting, I changed the title of the question. I don't think I had fcitx before installing it. (If I try to install again, I get a message that it is already installed. This list was empty under Chinese) Changing to fcitx is a bigger change, so I started by choosing sunpinyin (iBus), that seems to work. Later when I can risk some temporary loss of function, I will try fcitx. It comes up as a choice under language support, as described in this answer. – ycc_swe Aug 31 '16 at 6:24
  • The blank characters that show up between the character-pinyins ("ni hao") are introduced by iBus. To me they are not disturbing. you can just type long and press space at the end and it comes out ok. dajiahaonimenzenmeyang<space> seems to work fine so far, even if (sunpinyin) iBus may not be the recommended IME solution – ycc_swe Aug 31 '16 at 6:29
  • 2
    Fcitx is only installed by default in Ubuntu 16.04 if you choose one of the CJKV languages at installation. Consequently, for an English system (as is the OP's case) fcitx is not available as an option in Language Support until fcitx has been installed. Please see help.ubuntu.com/stable/ubuntu-help/… – Gunnar Hjalmarsson Sep 27 '16 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.