I installed Ubuntu 16.04 in an Acer R5-571T 59DC notebook for dual booting with the preinstalled Win 10 (UEFI).

After restart there is no GRUB menu and the PC boots directly on Windows.

I disabled secure boot and fast boot before install, and also used "boot repair" with a live usb. No luck.

I managed to start Ubuntu using Super Grub2 Disk, so I think GRUB is ok but without the super grub pendrive I cannot boot Ubuntu.

  • Did you disable "fast startup" in Windows? – wjandrea Aug 29 '16 at 0:54
  • Does the EFI boot menu (some function key at power-up) give you an ubuntu entry? Does it work? – ubfan1 Aug 29 '16 at 3:08
  • fast startup was disabled in Windows and in EFI boot menu only was Windows. – systemcrash Aug 30 '16 at 4:49
  • Now after enabling secure boot the option for adding Ubuntu to the EFI boot menu was enabled. The pc is still starting windows directly but I can stop it with the F12 key to show the menu and start GRUB – systemcrash Aug 30 '16 at 4:52

I found a good enough solution.

I enabled secure boot again in the UEFI settings and after that the option for adding the new OS to the EFI boot menu was enabled.

Now when I access it with F12 key I have both the Ubuntu & Windows options.

Thanks wjandrea for your answer


Upgrade, update the system, and install grub. After that your problem will get solved.

For update:

sudo apt-get update

For upgrade:

sudo apt-get upgrade

For installing grub, follow this link How do I manually install GRUB?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.