1

[noob here] I am trying to install CUDA 7.5 on my dell laptop which has both Intel and Nvidia GeForce 820M cards. Initially I installed it from .run file and went through so many problems like blackscreen on boot up, etc. After solving those, when I ran deviceQuery, I got error : No CUDA capable device detected. The error is right as I cant find /dev/nvidia* anywhere.

Here is my 'inxi -bG' output:

System: Host: shubh-Inspiron-3542

Kernel: 3.13.0-93-generic x86_64 (64 bit)

Desktop: Gnome 3.10.4

Distro: Ubuntu 14.04 trusty

Machine: System: Dell (portable) product: Inspiron 3542

Mobo: Dell model: 0926J6 version: A03

Bios: Dell version: A03 date: 05/27/2014

CPU: Dual core Intel Core i5-4210U CPU (-HT-MCP-) clocked at 782.00 MHz

Graphics: Card: Intel Haswell-ULT Integrated Graphics Controller X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.0hz

GLX Renderer: Mesa DRI Intel Haswell Mobile GLX Version: 3.0 Mesa 10.1.3

Network: Card-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter driver: ath9k

Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169

Card-3: Atheros

Drives: HDD Total Size: 1000.2GB (6.0% used)

Info: Processes: 207 Uptime: 5 min Memory: 1077.5/3857.5MB Client: Shell

I cant find NVIDIA card here;

But when I ran 'lspci | grep -i nvidia' , I got :

08:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] (rev a1)

Also for running 'dpkg -l | grep nvidia' , I got output:

rc bumblebee-nvidia 3.2.1-9~gpu14.04.1 amd64 NVIDIA Optimus support using the proprietary NVIDIA driver

rc nvidia-304 304.131-0ubuntu0.14.04.2 amd64 NVIDIA legacy binary driver - version 304.131

ii nvidia-340 340.96-0ubuntu0.14.04.1 amd64 NVIDIA binary driver - version 340.96

ii nvidia-common 1:0.2.91.11 amd64 transitional package for ubuntu-drivers-common

rc nvidia-opencl-icd-304 304.131-0ubuntu0.14.04.2 amd64 NVIDIA OpenCL ICD

ii nvidia-opencl-icd-340 340.96-0ubuntu0.14.04.1 amd64 NVIDIA OpenCL ICD

ii nvidia-prime 0.6.2 amd64 Tools to enable NVIDIA's Prime

ii nvidia-settings 331.20-0ubuntu8 amd64 Tool for configuring the NVIDIA graphics driver

Currently I have restored my system by installing old nvidia driver 340, and have CUDA 6.5 installed as I was experimenting it with nvidia 340 driver. However,I want CUDA 7.5 to be installed in my machine if possible. I am fed up from re-installing nvidia driver for getting black screen upon boot up. Please help me with the issue. Thanks

0

If you're willing to upgrade, I successfully deployed CUDA on an unencumbered NVIDIA GPU in 16.04 .. these steps may even work in 14.x as long as you mimic the instructions regarding the .run files

Severe under performance of CUDA vs Windows, make intel primary GPU?

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.