1

I'm having problems with my tty terminals. When I boot up, the tty's work nicely for some time. But after about an hour of usage or so, when I switch to a tty, I am greeted with a static login prompt without a blinking caret. All the tty's show tty6 on the top. I can log in by typing my credentials blindly and can even switch back to gui using 'sudo chvt 7', but the screen remains static. tty7 works fine but I'll be damned if something goes wrong with the gui. So it would be nice if I could get it working. Any help would be highly appreciated.

Here's the content of my /etc/default/grub, if it's of any help:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that  obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
GRUB_GFXPAYLOAD_LINUX=text
2

Arch linux forum has the thread related to this problem. Their problem was resolved by switching to a newer kernel. The same worked for me. I had to install kernel 4.6.

Here is a step by step guide for the same.

wget http://in4serv.com.br/backup/kernel-4.8.1-stable
sudo chmod +x kernel-4.8.1-stable
sudo ./kernel-4.8.1-stable
sudo reboot

kernel-4.8.1-stable script:

#!/bin/sh
echo "$(tput setaf 3)--- (www.ubuntumaniac.com) | Kernel 4.8.1 Stable will be installed in an `uname -i` system ---$(tput sgr0)"
echo ""
sleep 2
read -p "Press Enter to continue, or abort by pressing CTRL+C" nothing
echo ""
echo ""
#i386 links
link1="http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8.1/linux-headers-4.8.1-040801_4.8.1-040801.201610071031_all.deb"
link2="http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8.1/linux-image-4.8.1-040801-generic_4.8.1-040801.201610071031_i386.deb"
link3="http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8.1/linux-headers-4.8.1-040801-generic_4.8.1-040801.201610071031_i386.deb"
#amd64 links
url1="http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8.1/linux-image-4.8.1-040801-generic_4.8.1-040801.201610071031_amd64.deb"
url2="http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8.1/linux-headers-4.8.1-040801-generic_4.8.1-040801.201610071031_amd64.deb"
#System architecture
arch=`uname -m`
if  [ $arch = i686 ] || [ $arch = i386 ]; then
mkdir -p $HOME/kernel-i386 
cd $HOME/kernel-i386
wget -c $link1
wget -c $link2
wget -c $link3
sudo dpkg -i $HOME/kernel-i386/*.deb  
sudo rm -rf $HOME/kernel-i386
elif [ $arch = "x86_64" ]; then
mkdir -p $HOME/kernel-amd64
cd $HOME/kernel-amd64
wget -c $link1
wget -c $url1
wget -c $url2
sudo dpkg -i $HOME/kernel-amd64/*.deb  
sudo rm -rf $HOME/kernel-amd64
     else
        echo "Unsupported Architecture"
fi

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.