3

After upgrading to ubuntu 16.04 I can no longer sync my iPod touch (MC008FD, 3rd generation, 32 GB - yes, I know it's an old model, but I really like that one) with Rhythmbox. The device is simply ignored and does not show up in the panel on the left.

Attempts to use amarok and gtkpod instead of Rhythmbox were unsuccessful. While amarok apologizes ("Sorry - Connecting to iPhone, iPad or iPod touch failed"), gtkpod simply pretends that there is no device. However, the iPod is recognized by the system when I plug it into the USB port: it is displayed in the launcher along with its documents. Alas, the music remains inaccessible.

A couple of the relevant libraries are already installed:

~$ dpkg -l libgpod4 libimobiledevice6  libplist3 usbmuxd libusbmuxd4
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                      Version           Architecture      Description
+++-=========================-=================-=================-========================================================
ii  libgpod4:amd64            0.8.3-6ubuntu2    amd64             library to read and write songs and artwork to an iPod
ii  libimobiledevice6:amd64   1.2.0+dfsg-3~ubun amd64             Library for communicating with the iPhone and iPod Touch
ii  libplist3:amd64           1.12-3.1          amd64             Library for handling Apple binary and XML property lists
ii  libusbmuxd4:amd64         1.0.10-2ubuntu0.1 amd64             USB multiplexor daemon for iPhone and iPod Touch devices
ii  usbmuxd                   1.1.0-2           amd64             USB multiplexor daemon for iPhone and iPod Touch devices

I understand that a number of similar questions have been asked before, and I made sure to read the pertinent posts, like "How to sync songs in Rhythmbox with an iPod" and "Syncing iPod touch", as well as various documentations provided, e.g., here and here before asking this question. Possibly I have overlooked something, but I have tried for some time and could not find any answer or hint that would solve the problem.

What surprises me is that Rhythmbox used to sync with that same iPod seamlessly with ubuntu 15.10. The appearance of the problem seems to have coincided with the OS upgrade. I am therefore reluctant to resign myself to concluding the that "it just doesn't work".

I would be very grateful for suggestions on how to resolve this issue.

3

The issue is now solved to a sufficient degree in the sense that the iPod is recognized by amarok and by gtkpod. (Rhythmbox still does not see that iPod on ubuntu 16.04).

Because I have tried many things to resolve the problem, I am not sure what exactly made the difference. But I believe that the following commands were important:

sudo apt-get install fuse libimobiledevice-utils ideviceinstaller
idevicepair pair    
chmod 777 /media/iPod
ifuse /media/iPhone/

Further, I edited the file /etc/fuse.conf and uncommented the line user_allow_other therein. Essentially I followed the steps described in detail here.

I post this as an answer to my own question, hoping that it will be helpful for others. In any case, as far as I'm concerned, the problem is solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.