0

Im new to Linux. Have to install Ubuntu for some school work, but I didn't want to lose my current windows so I installed Ubuntu in a different Partition from the Windows one.

It installed correctly and everything but now whenever I switch on the laptop or restart it, it automatically boots Windows 10.

The only way i can use Ubuntu is if I boot a LiveUSB and choose the 'Try Ubuntu' option. How do I get my computer to show me the "Choose OS Screen"?

Using Dell Inspiron laptop

  • Check this and this – Shashanth Aug 28 '16 at 6:19
  • 1
    Unrelated but since you are new to linux and dual-booting windows 10 with linux you may or may not run into the issue where ubuntu decides to go into "Emergency mode" for no reason whatsoever. If you see this and didn't do anything insane before rebooting, DO NOT PANIC. This probably means that windows is in hibernate mode and not letting ubuntu use the disk properly. So simply reboot into windows and shut it down properly. – Slava Knyazev Aug 28 '16 at 6:28
  • Use VirtualBox inside Windows if you like to install Ubuntu. That's much saver then screwing up you system. – 0x0C4 Aug 28 '16 at 6:36
  • Can you post your PC brand? Is it HP? if yes, I have the solution: just keep pressing F9 incessantly during start up and choose ubuntu option. This screen should appear before HP logo. you must be fast! – Vitor Abella Aug 28 '16 at 6:43
  • @Vitor Its Dell Inspiron – Usman Shahid Aug 30 '16 at 12:22
0

Go to your BIOS settings and search for Boot options>Secure Boot and disable it. From Windows 8.1 Microsoft has introduced UEFI firmware to provide safety from rootkit malware and what is happening here is that Windows Boot Manager is bypassing GRUB bootloader. Boot into Windows and Go to Control Panel>Power Settings>Choose what power button does and disable fast startup. If you are still unable to boot into Ubuntu then boot into Windows and open Administrator's Command Prompt and run this command.

bcdedit /set "{bootmgr}" path \EFI\ubuntu\grubx64.efi

You should be able to see GRUB bootloader.

  • None of the above worked – Usman Shahid Aug 30 '16 at 12:43
  • then you definitely didn't install GRUB bootloader correctly. – Shahzaib Rahim Aug 30 '16 at 12:53
  • Tbh I just installed Ubuntu from a LiveUSB. Help me out? – Usman Shahid Aug 30 '16 at 15:21
  • 1
    i also installed Ubuntu with LiveUSB. It really doesn't matter. what you can do is startover by uninstalling it first and then reinstalling it. – Shahzaib Rahim Aug 30 '16 at 15:56
  • What software did you use to create LiveUSB (bootable disk)? – Shahzaib Rahim Aug 30 '16 at 17:01
0

So I finally fixed it. Turns out both Windows 10 and Ubuntu were installed in Legacy Mode and there was a problem with the bootloader. I ran the 'boot-repair' from Ubuntu on a LiveUSB which re-installed the GRUB Bootloader and everything was good.

Posting this answer in case someone else runs into the same issue.

Thanks for the help, ya'all :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.