1

I am unsuccessfully trying to do what is described in this thread: create a larger than 4GB persistence for my Live USB for Ubuntu. My goal is to have a portable version of Ubuntu with persistence that I can use across more than one machine.

Here is what I have done:

  1. Created a live USB for Ubuntu 16.04.1 LTS on a 16GB USB flash, which I will call usb16gB, using pendrivelinux.

  2. Booted Ubuntu from usb16GgB on laptop.

  3. Inserted a 128GB USB flash, which I call usb128gB, into a USB port on this laptop running Ubuntu.

  4. Used GParted to create two partitions on usb128gB: a 33.49GB FAT32 partition and a 82.2GB ext2 partition that is labeled casper-rw. GParted shows that the casper-rw partition has 1.34GB used.

Note 4a: I have made multiple attempts to create a partition labeled casper-rw. In my first attempt, I had live USB already installed onto usb128gB and then used GParted. It is for subsequent attempts that I created the partitions first and then created USB Live in the Fat32 partition.

Note 4b: After my first attempt I kept getting an error when I tried to align the partitions to cylinders. I have currently aligned them to MiB. I also found the following text in the GParted manual.

Specifying Partition Alignment To specify the alignment of the partition, click the Align to arrow button, and select from the list. Use MiB alignment for modern operating systems. This setting aligns partitions to start and end on precise mebibyte (1,048,576 byte) boundaries. MiB alignment provides enhanced performance when used with RAID systems and with Solid State Drives, such as USB flash drives.

Use Cylinder alignment to maintain compatibility with operating systems released before the year 2000, such as DOS. This setting aligns partitions to start and end on disk cylinder boundaries.

Note 4c: The casper-rw partition has an empty folder called upper, and empty folder called work, and a file named Format. Opening Format with a text with gedit shows:

# This records the union filesystem format used for this cow medium; do not delete or alter. UNIONFS=overlay

Using Terminal to look at contents of casper-rw partition also shows a folder called lost+found which has restricted access.

  1. Rebooted laptop to launch Windows 10. Used penlinuxdrive Universal USB Installer to create Live USB in the Fat32 partition of usb128gB. I selected the Format Drive option and create a ~500MB persistence file.

  2. I reboot into Ubuntu using Live USB on the smaller USB flash, usb16gB. I delete (move to trash) casper-rw from the larger usb flash, usb128gB.

  3. I reboot into Ubuntu this time using Live USB from the larger USB flash, usb128gB. I see the cycling dots when Ubuntu is launching. I then see this error:

[ 0.234677] platform MSFT0101:00: failed to claim resource 1 [ 0.234684] acpi MSFT0101:00: platform device creation failed: -16 [6.417393] EFI: Problem loading in-kernel X.509 certificate (-74)

BusyBox v1.22.1 (Ubuntu 1:1.22.0-15Ubuntu1) built-in shell (ash) Enter 'help' for a list of built-in commands.

(initramfs)

The cursor blinks immediately to the right of the (initramfs).

Pasting a casper-rw file (saved on a different disk during one of the attempts to delete it from usb128gB) into the Fat32 partition of usb128gB enables it to successfully boot.

I achieve the same failure/error if I rename casper-rw on usb128gB to backupcasper-rw. If I change backupcasper-rw back to casper-rw then I am able to boot ubuntu again from from usb128gB.

So it seems that removing casper-rw is interrupting the boot process, which is different than what I see in the thread I reference at the top of this question. Per that thread I should be able to delete casper-rw and that the partition should automatically become associated with the Live USB for persistence.

Does anyone have any insights or suggestions to offer?

Thanks for any help.

2

Persistent partitions have not worked with syslinux type installs, (SDC, Unetbootin, Pendrivelinux, Universal), since 14.04.

If you want to use persistent partitions nowadays you need to use a grub2 type installer, (mkusb or dus).

Mkusb can make persistent partitions and format any remaining space to NTFS so it can be used by Linux or Windows.

https://help.ubuntu.com/community/mkusb

Edit Aug/2017 - Persistence files > 4GB

Syslinux started adding support for NTFS with version 4.06 but did not offer full support until version 6.03.

UNetbootin - 655 uses Syslinux 4.03 and is limited to 4GB persistence files per FAT32.

MultiBootUSB - 8.8 uses Syslinux 4.07 and will install on NTFS, persistence files are not limited to 4GB.

Rufus 2.16 uses Syslinux 6.03 and will install on NTFS, persistence files are not provided but can be added manually and are not limited to 4GB.

YUMI - 2.0.4.9, (MultiBoot USB), uses Syslinux 6.03 and will install on NTFS, persistence files are not limited to 4GB. Like MBUSB 8.8 it can have persistence files for each distro installed.

  • I think a lot of people just wants a bigger /home, though. Nothing prevents automounting a different partition for that, is there? – Jo-Erlend Schinstad Aug 15 '17 at 19:21
  • For a Persistent home folder or partition you can use home-rw, (similar to casper-rw). – C.S.Cameron Aug 15 '17 at 20:01
  • I used mkusb and I now have what I was trying to achieve! Thanks for the thorough response. – user3600280 Mar 17 '18 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.