1

Using Ubuntu 16.04, I would like to employ iBus to use Sanskrit transliteration (sa-iast) as a text-input source. But I don't see how to do it.

To add an input source in Ubuntu 16.04 would seem an easy, straightforward process:

  1. Make sure iBus and iBus-m17n are installed.

  2. Go to "Settings / Language support." Choose iBus as the "input method system." Then click "Close."

  3. Go to "Settings / Text entry." Under "Input sources to use," click "+" A list will then appear. From the list, choose your input source. Click "Add" and you're done.

In practice, adding an input source doesn't always seem so simple.

In my case, the problem is that the source I wish to use doesn't appear on the list.

The file "sa-iast.mim" does appear in usr/share/m17n. This would seem to indicate that this input source should be available. But in the "Choose an input source" dialogue, it doesn't appear.

I do see "Sanskrit (KaGaPa phonetic)," but this is an entirely different source, meant for input of the Devanagari script, not IAST roman transliteration.

I have both "English" and "Hindi" running fine as input sources.

Some answers to other questions mention running "ibus-setup" from the terminal. When I do that, I receive this error message:

(ibus-setup:5524): IBUS-WARNING **: The owner of /home/jswami/.config/ibus/bus is not jswami!
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

I then get a message that the iBus daemon is not running. When I am asked whether I want to start it and I answer yes, I receive this message:

(ibus-daemon:5534): IBUS-CRITICAL **: 18:31:00.656660: ibus_write_address: assertion 'pf != NULL' failed

So what should I do?

  • Please do not add "SOLVED" to the title. – edwinksl Sep 16 '16 at 23:03
0

The relevant warning was "The owner of /home/jswami/.config/ibus/bus is not jswami!" I must have messed with the file, so that the owner was root. Changing the permissions so that I once again became the owner fixed the problem. (To do this, right-click the filename, click "Properties," choose the "Permissions" tab, and change the Owner.) Now everything works.

Documentation on what to expect when you install m17n is fairly scarce. I was helped by this post: http://netgator.blogspot.com/2010/10/ibus-problem-on-ubuntu-1010-solved.html.

Part of what's helpful is knowing what to expect. Suppose you have installed IBus and m17n. You've clicked on "System Settings" and chosen "Language Support." There, for your "Keyboard input method system," you've chosen "IBus." Now, also under "System Settings," you chose "Text Entry." There, under "Input sources to use," click the plus sign (+). You should see a wide array of choices, many of them with "(m17n) (IBus)" after the language name. If you don't see that, something is wrong (as it was for me).

In troubleshooting, you may find it helpful to use the "System Monitor" program (installed in Ubuntu by default) to make sure that IBus is present under the "Processes" tab. There you should see several IBus processes, such as "ibus-dameon." If you don't, then again something is wrong. IBus hasn't been started.

Despite what you may read in older posts, you shouldn't need to manually set up IBus as a startup application. It should automatically start when you log in.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.