0

I was running lubuntu Xenial but was unable to get the headphones working after trying all of the different possible fixes I could find. I have finally given up on trying to fix it myself and have come to you all for help (by actually asking a question).

The sound works for the integrated laptop speakers, however the 3.5mm audio jack does not seem to be recognized by the OS. Additionally, there is no 'headphone' option in the sound settings, nor in alsamixer, nor in any other sound gui or command line interface I can find.

I have uninstalled and reinstalled alsa and pulseaudio to no avail and finally tried to just do a fresh install of ubuntu xenial (which I am now talking from) but this did not solve the problem.

Please assist if you can. Thanks!

alsa-utils.sh output: http://pastebin.com/raw/86myHZ4x

    $USER:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CA0132 Analog [CA0132 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: CA0132 Digital [CA0132 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Headphones are now recognized if I go into alsamixer and enable HP/Speaker Auto Detect and run sudo alsa force-reload

Possibly one step closer... I did this:

sudo apt-get install alsa-tools-gui
hdajackretask

Which allowed me to override the 'Orange Headphone, Front side' pin 0x10 with 'Headphone' which makes it so that ubuntu recognizes when the headphones are plugged into the correct headphones port. Still no sound coming into them, but at least it knows when it's plugged in.

Also have to run ps -ef | grep pulseaudio run kill <pulseaudio-pid> && sudo alsa force-reload to get the snd-hda-intel module to reload but doing so kills the headphone recognition again.

  • Also, I'm terribly sorry for misspelling Xenial in the title. Fat fingers – Jahat120 Aug 27 '16 at 20:50
  • Did you try this? – MicroParsec Aug 27 '16 at 21:22
  • I tried that, one step closer I think. I modified that line then did 'sudo alsa force-reload' went into alsamixer and turned on 'HP Auto-detect' and now the headphones are showing in pavucontrol. However, there's still no sound coming from the headphones. I also tried using different headphones but there still isn't any sound coming out. – Jahat120 Aug 28 '16 at 15:40
  • Did you reboot after changing the modprobe.d file? – MicroParsec Aug 28 '16 at 15:44
  • Yes, I've rebooted a couple of times now. It also seems that the problem may be with Alienware's choice of sound card... the creative sound blaster doesn't seem to have a whole lot of support for linux. That said, I do finally see headphones (plugged in) in pavucontrol. Gonna do another reboot just to see if something magically fixes itself. Also, there is a headphone port and a microphone port on the alienware and the headphones plugged in port only shows up when I plug into the microphone port. Not sure if maybe that has something to do with it... Trying to figure out how to swap them out. – Jahat120 Aug 28 '16 at 15:52
0


I just install Ubuntu 16.04 right now and my headphones were enjoying the silence. After 2 minutes of hardcore googleing I found this link.

The relevant information its shown below:

Fix issue with headphones not working: –

Open Terminal
alsamixer
Press F6
Select “HDA Intel PCH” card
Press right arrow till the Item shown is “HP/Speaker Auto Detect”
Press M to set it on.
Connect headphones and verify if it works.

Follow step by step the instructions and swept up with music!

  • I think the issue is that the alienware 17 r3 drivers are not supported yet by alsa/pulseaudio. I bought a usb sound card as a workaround which works well enough. – Jahat120 Oct 9 '16 at 2:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.