5

I want to have Google Noto Color Emoji replace all other emojis, so I dont see the generic ones. Like this one here: enter image description here

To test this, I use the follow page: http://getemoji.com/ which displays "all" the emojis the browser can use. As you can see, there just a few missing.

I suspect that some other font might have a higher priority, so it tries to use that before Noto Color Emoji.

I can kind of work around this with the follow: If I simply do this, it will work on sites like http://getemoji.com but not on facebook and other social sites.

  <match>
    <test name="family"><string>Segoe UI</string></test>
    <edit name="family" mode="assign" binding="strong">
      <string>Noto Color Emoji</string>                                         
    </edit>
  </match>

I currently use these lines in .config/fontconfig/fonts.conf, to make sure they work in Google Chrome

<!-- Emojis -->
  <match target="scan">
    <test name="family">
      <string>Noto Color Emoji</string>
    </test>
    <edit name="scalable" mode="assign">
      <bool>true</bool>
    </edit>
  </match>

  <match target="pattern">
    <test name="prgname">
      <string>chrome</string>
    </test>
    <edit name="family" mode="prepend_first">
      <string>Noto Color Emoji</string>
    </edit>
  </match>

I have tried to remove all microsoft fonts, symbola-fonts and others to figure out what font is doing this, but I cant figure it out :(

Ubuntu 16.04.1 with: Noto Color Emoji

Maybe someone with some developer tools in a browser can figure it out? I have tried but can't find it.

  • I'm afraid it's not a font; it seems you are missing an image file for the emoji... – EKons Aug 31 '16 at 16:32
  • Don't think so, but not sure.. If I use Emoji one instead, it's the same thing. If I remove them both, I can see just that one "emoji" So it must come from somewhere? – Joakim Koed Aug 31 '16 at 17:40
  • I checked the page you linked and don't see the color emojis you display in your question so I'm not sure what you are asking (or exactly what http://getemoji.com/ has to do with your question. Would you be so kind as to edit your question to make it more clear and help us help you in the process? Thank you. – Elder Geek Sep 3 '16 at 18:11
  • @ElderGeek Does it make more sense now? – Joakim Koed Sep 4 '16 at 10:10
2
+100

If I understand your question, I don't think you can resolve the problem on social sites like Facebook or Twitter as Twitter & Facebook use their own emoji-replacement-images for users of the desktop website. This works around issues of emoji compatibility and also gives a chance for branding in the emoji set.

Further, removing fonts will not extend the capability of your system. I suggest that you may wish to reinstall the fonts you removed due to the theory that they were taking precedence somehow.

As far as the "few missing" emojis you mention you may be interested to know that "The particular issue here is that while the glyphs are present in the B/W emoji font with a cmap entry mapping a single character to each (couple with heart 1f491, kiss 1f48f, and family 1f46a), there are no GSUB entries that map these sequences to them." <-Quote Source

You can track all the existing issues with Noto-emoji here

Original Source: http://blog.emojipedia.org/new-to-emojipedia-samsung-facebook-emoji-one/

  • I understand that facebook and twitter will replace most emojis with their own, but like that specific one in the picture is not getting replaced and is still the black and white one. facebook and twitter was just an example, it is like this for ALL sites. – Joakim Koed Sep 5 '16 at 11:24
  • Ah, well as I tried to indicate in an earlier comment .. I guess I'm still not clear where you are getting that image from as I couldn't find it with either of the links you provided. – Elder Geek Sep 5 '16 at 17:13
  • Elder Geek: If you go to getemoji.com you should see all the emojis your browser / fonts are able to show. The reason I see this is because I use Noto Color Emoji from Google. – Joakim Koed Sep 6 '16 at 12:36
  • Updated answer to cover the missing emojis – Elder Geek Sep 6 '16 at 17:34
  • Seems you are correct, that it might be the font missing it. I see on github.com/googlei18n/noto-emoji/issues/43 it's the same with chrome on windows and MS's emojis. Thank you for explaining. Also I ofcourse did install the fonts I tried ti remove during testing. You shall receive ALL the points.. :D – Joakim Koed Sep 7 '16 at 6:28
0

The method I'm going to tell you is currently working only in Chrome, and I'm looking for a way to make it work in Firefox too:

Add these lines in your fonts.conf before the last </fontconfig> line:

<alias>
        <family>sans-serif</family>
        <prefer>
            <family>Noto Color Emoji</family>
        </prefer>
</alias>
<match>
    <test name="family"><string>Segoe UI Emoji</string></test>
    <edit name="family" mode="prepend" binding="strong">
        <string>Noto Color Emoji</string>
    </edit>
</match>

Restart Chrome.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.