8

History

  • I have Ubuntu. Because of its extraordinarily slow speed (especially after upgrading to 16.04 from 14.04, almost as slow as Windows), I installed lubuntu-desktop and now use Lubuntu. The change has greatly speeded my computer.
  • I am able to choose whether to boot into Ubuntu or Lubuntu each time I log in.
  • After this change, in Lubuntu, the automatic suspend would not work because it asked for the password. I fixed this using the solution to Authentication required before suspend.

Problem

When I resume from automatic suspend, I am greeted with an unusual login screen, which has only three elements:

  • The day and time
  • The title "Light Display Manager"
  • A prompt to enter a password without a user being displayed

When I enter my password, the prompt responds with, "Incorrect password". I have, of course, tried multiple times and typed my password carefully.

I cannot proceed from that screen, and even Ctrl+Alt+Delete doesn't work. I have to use REISUB. EDIT: I can also sign into a console (Ctrl+Alt+F1) and sudo reboot.

Extra notes

If I suspend manually, or if I use Ubuntu, the computer resumes properly with the correct login screen, accepting my password and allowing me to continue. Only the automatic suspend from Lubuntu gives this problem.

Question

How do I get the computer to resume correctly from automatic suspend when using Lubuntu?

  • The lubuntu-desktop metapackage installs the xfce4-power-manager so maybe the problem is that both xfce4-power-manager and gnome-power-manager are active. Try to disable suspend from the gnome-power-manager and enable it at xfce4-power-manager. – Thanos Apostolou Aug 27 '16 at 14:44
  • Do you see the same issue with a pure Lubuntu installation? – DK Bose Aug 28 '16 at 1:27
  • @ThanosApostolou : Thanks, but unfortunately it doesn't help. – Paddy Landau Aug 28 '16 at 12:36
  • @DKBose : Sorry, I'm not going to reformat my drive and do a full installation. I don't have that sort of time! – Paddy Landau Aug 28 '16 at 12:37
  • Hmmm light-locker is also installed with lubuntu-desktop, so maybe try to disable it or remove it by sudo apt purge light-locker. – Thanos Apostolou Aug 28 '16 at 13:39
0

This solved my problem

sudo apt remove gnome-screensaver

There is a conflict between screensavers as LightDM starts up gnome-screensaver when the device goes into suspend at the lock/login screen.

0

For a quick temporary fix:

  • Login to a terminal, use CTRL+ALT+F1 or ...+F2 etc.

  • Kill light-locker as admin: sudo pkill light-locker

  • this only solves the problem temporarily – João Pimentel Ferreira Jan 15 at 20:40
  • It helped me when I needed to be quick. Too bad I pressed switch user which somehow killed my old session. – Martijn Weterings Jan 25 at 16:25
-1

Edit /etc/lightdm/users.conf as administrator. In the [UserList] section, make sure you have

hidden-users=nobody nobody4 noaccess lightdm

(user lightdm is often missing)

  • 1
    Thank you for the reply, @ced. I had other issues that forced me to reinstall Lubuntu from scratch. So, I can't check if your solution would have worked :( Incidentally, you used Windows backslash instead of the normal forward slash for the path :D – Paddy Landau Jul 25 '17 at 14:57
  • Oops. I typed the path manually. Old habits are difficult to quit. Ashamed. – ced Jul 25 '17 at 16:34
  • tried and doesn't work! – João Pimentel Ferreira Jan 15 at 20:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.