1

I am aware that the sound issue with PPC G5s (PowerPC) has been discussed in quite a few posts in several forums and communities and it was marked "Fixed". But these solutions do not work for me / on my box.

I recently installed Ubuntu MATE 16.04 on my G5 PPC, dual booting with OS X 10.5.8. Everything looked and worked pretty well after installation, with the exception of sound and WiFi.

Regarding sound I had the typical phenomenon with "dummy audio" being said and no audio device listed in system settings. Alsamixer crashed when selecting Edit » Sound Card Properties obviously because there was no sound card recognised.

The PowerPC FAQ says the file /etc/modprobe.d/blacklist.local.conf should be deleted, but I do not have such file on my system. What I have is a blacklist.conf and seven more blacklists in this directory, but none of those seems to adress sound.

I added the following to /etc/modules:

snd_aoa_i2sbus
snd_aoa_fabric_layout
snd_aoa_codec_tas
snd_aoa_codec_onyx

As a result there is now a sound card listed in settings:

K2 KeyLargo Mac/IO

Both in settings and ALSA the device can be edited. But still no sound what ever the settings are.

In OS X it says the sound card is a Texas Instruments TAS3004. How do I get this to work?

4
  • Welcome to Ask Ubuntu! Please post the output of cat /proc/device-tree/model and find /proc/device-tree/ -name layout-id | xargs hexdump -e '1/4 "0x%x\n"' as specified here. Aug 27, 2016 at 11:57
  • thx Andrea. Will post this output right away. Although I got sound working after DELETING the entry: snd_aoa_codec_onyx from /etc/modules and leaving only the entries snd_aoa snd_aoa_soundbus snd_aoa_i2sbus snd_aoa_fabric_layout snd_aoa_codec_tas added. I followed an advise from "tomi" on ubuntu-mate.community.
    – Ulrich
    Aug 28, 2016 at 21:24
  • +Andrea, here is the output as requested (indented): cat /proc/device-tree/model PowerMac7,3 find /proc/device-tree/ -name layout-id | xargs hexdump -e '1/4 "0x%x\n"' 0x24 Does that help? As I said in previous comment: I got sound working following an advise on ubuntu-mate but it is a bit frustrating for me as I do not understand what I am actually doing by adding or deleting these entries.
    – Ulrich
    Aug 28, 2016 at 22:16
  • If you solved the question do not leave the solution as a comment. Please write a self answer instead. :-) Aug 28, 2016 at 23:19

1 Answer 1

1

I finally got it working. As recommendations and fixes given in several forums look a bit inconsistent to me this answer explains what I did for the fix.

After a fresh installation of Ubuntu Mate 16.04 on my PPC G5 there was only one entry in the file /etc/modules (i.e. kernel modules to load at boot time):

apm_emu

The following entries (and only these) need to be added to /etc/modules:

snd_aoa
snd_aoa_soundbus
snd_aoa_i2sbus
snd_aoa_fabric_layout
snd_aoa_codec_tas

Do not make an entry:

snd_aoa_codec_onyx

In Terminal start gnome-alsamixer. Check if there is something set on "mute". If this is the case, unmute it. Check the sound levels. Be aware that the sliders show the respective levels the other way round compared to System → Settings → Sound.

If a slider is at the top position (and the trail of the slider is all grey, not green) then it is set to 100%. Adjust both Master and PCM to 100%. With a setting of 70% or less I did not have any signal at the speakers in the next step. Headphone Detect Autoswitch and Line-Out Detect Autodetect should be selected.

Then close alsamixer and go to:

System → Settings → Sound

There should now be a sound card listed on the device tab. In my case it is K2 KeyLargo Mac/IO (which is odd as in Mac OS X it says Texas Instruments TAS3004). On the Sound effects tab warnings might be leveled to zero or muted. Adjust as needed but this will probably be set to zero and/or muted each time after startup.

On the Device tab you can select a device. In my case I have 4 options to chose from:

  1. Analog Stereo Duplex
  2. Analog Stereo Output
  3. Analog Stereo Input
  4. Off

Between the two first I could not identify any differences both with headphones connected in the front and speakers connected in the rear of the G5. Click on Speakers Test right next to the selection list. On the next screen you should see something like Front Left and Front Right probably depending on what you have connected with two respective Test buttons.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .