3

I don't understand why my apt-cache would be empty, as there is a gazillion packages installed on my system (like all Ubuntu systems). I tried installing a random program and running it thinking that it might just show temporary packages, but got the same result.

  • Did you try to execute apt-get update to update the package index? – Thomas Aug 27 '16 at 9:35
  • 4
    In any case the error message is quite unhelpful. Instead of being E: no packages found it should be something like E: missing operand package name or similar that might give a hint that it's on the command line that something is missing, not on the system. – Bakuriu Aug 27 '16 at 18:54
  • 2
    What exactly you ran? apt-cache show sdjaf shows "E: No packages found", because sdjaf isn't a package that exist in the package lists. – Braiam Aug 27 '16 at 19:05
9

The apt-cache show (or apt show) command needs an argument: the name of a package:

$ apt-cache show gimp
Package: gimp
Priority: optional
Section: universe/graphics
Installed-Size: 16188
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Ari Pollak <ari@debian.org>
Architecture: amd64
Version: 2.8.18-1

... and many more lines

Perhaps you want apt list to see available packages or apt list --installed for installed packages?

  • lol, was just looking at some notes i made and it appears i was confused about the purpose of the program due to some shitty note taking...this thread should be removed – thinksinbinary Aug 27 '16 at 10:11
  • Hehe well I guess others could make the same mistake @thinksinbinary – Zanna Aug 27 '16 at 10:20
  • 2
    @thinksinbinary Somehow this made it to the Hot Network Questions list, so apparently enough find it interesting... – Izkata Aug 27 '16 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.