1

I had used Roland QUAD-CAPTURE on Ubuntu 16.04.1 without any problems. But it can't play audio suddenly since some days ago. I tried to fix this problem by un-muting devices, upgrading kernel, changing USB cable, but it still can't play anything.

Issues

  • Can't play audio with Roland QUAD-CAPTURE on Ubuntu 16.04.1.
    • Before, it can play audio without any problems.
    • In another device, NVIDIA HDMI can play audio.
    • It works on Windows. (it may not be physical device issue.)

some debug informations

aplay -l

 # aplay -l
 **** List of PLAYBACK Hardware Devices ****
 card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
 card 0: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
 card 0: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
 card 0: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
 card 1: QUADCAPTURE [QUAD-CAPTURE], device 0: USB Audio [USB Audio]
   Subdevices: 0/1
   Subdevice #0: subdevice #0

aplay -vv /usr/share/sounds/alsa/Front_Center.wav

aplay stuck in following state.

 # aplay -vv /usr/share/sounds/alsa/Front_Center.wav 
 Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
 ALSA <-> PulseAudio PCM I/O Plugin
 Its setup is:
   stream       : PLAYBACK
   access       : RW_INTERLEAVED
   format       : S16_LE
   subformat    : STD
   channels     : 1
   rate         : 48000
   exact rate   : 48000 (48000/1)
   msbits       : 16
   buffer_size  : 24000
   period_size  : 6000
   period_time  : 125000
   tstamp_mode  : NONE
   tstamp_type  : GETTIMEOFDAY
   period_step  : 1
   avail_min    : 6000
   period_event : 0
   start_threshold  : 24000
   stop_threshold   : 24000
   silence_threshold: 0
   silence_size : 0
   boundary     : 6755399441055744000
 ######            +                                | 34%
4
  • How is PulseAudio configured? – CL. Aug 27 '16 at 6:40
  • @CL. completely default, except volume settings. – Melvin A. Tirado Aug 27 '16 at 7:03
  • So PA is configured to play to some HDMI output? – CL. Aug 27 '16 at 7:13
  • No. In testing, I changed output device to use QUAD-CAPTURE. – Melvin A. Tirado Aug 27 '16 at 7:16
0

I found the way to fix this problem. This problem may be caused by mismatching of sampling rate?

Requirement

  • Environment running Windows or OS X
  • QUAD-CAPTURE Driver (To fix, need software control panel)

How to fix?

  1. Open software control panel
    • Windows: Open in control panel
    • OS X: There may be in /Applications/Roland*
  2. Reset configuration in "Device" menu
  3. Change sample rate to 44.1 kHz

Memo

alsa-capabilities

 4) USB Audio Class Digital alsa audio output interface `hw:1,0'
 - device name       = QUAD-CAPTURE                                                
 - interface name    = USB Audio                                                   
 - usb audio class   = 2 - isochronous asynchronous                                
 - character device  = /dev/snd/pcmC1D0p                                           
 - rates per format  = S32_LE:              44100Hz                                
 - monitor file      = /proc/asound/card1/stream0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.