0

I have a Steinberg UR824 audio interface with two boxes plugged in. Since the interface has many inputs and outputs, VLC assumes it's a surround system even though it's only stereo.

When I play a video, I can only hear what's coming from the surround speakers from the front. Mostly music and some sound effects, but mostly no dialogs.

Is there a way to force VLC into stereo mode?

  • "Audio" / "Audio Device"? – CL. Aug 27 '16 at 6:39
  • Yes, but what do you mean exactly? – fluxkompensator Aug 27 '16 at 7:31
  • What devices are listed there? – CL. Aug 27 '16 at 9:20
  • In the system settings the HDMI / Displayport NVidia output, my onboard Realtek Built-in Audio, and Multichannel Output - Steinberg UR824. In the VLC Preferences, when I set the output module to ALSA, I can chose a ton of variations for each of these devices. None of the variations for my audio interface seem to work. Also found "Force stereo" somewhere, which didn't help neither. The sound output through my monitor with the Nvidia drivers works perfectly, though. – fluxkompensator Aug 27 '16 at 9:47
  • If no working stereo device is listed, then the hardware does not support playback with only two channels. You have to configure PulseAudio to treat it as a stereo device. – CL. Aug 27 '16 at 9:56
0

Found a solution to this problem in this tutorial:

https://thedarkgod.wordpress.com/2013/08/26/having-pulseaudio-downmix-surround5-1-to-stereo/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.