8

I'm trying to learn Vulkan, so I install the Mesa Vulkan drivers and development files.

I downloaded some examples. I compiled the examples and tried to execute one. But when I run the file from terminal, it gave one warning and error:

WARNING: Haswell Vulkan support is incomplete
Error: No DRI3 support

I ask it from the person who wrote the example program, he said I have to enable the DRI3 for the running program. How can I do it in Ubuntu 16.04?

When I open the file "/etc/X11/xorg.conf", I see this:

Section "Device"
    Identifier "Default Card 0"
    BusID "PCI:0@0:2:0"
EndSection

What I need to do?

My environment: I'm using Intel Core i5 and Intel Haswell GPU.

0

1 Answer 1

4

Open this file: /etc/X11/xorg.conf.d/20-intel.conf as root and make the device section look like this

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "DRI"    "3"
EndSection

This is from the Arch wiki for Vulkan.

5
  • When i try to open and save it as root with gedit, it gives this error: Could not find the file “/etc/X11/xorg.conf.d/20-intel.conf” Aug 26, 2016 at 19:02
  • If it does not exist, you can just make it. Then reboot.
    – Mark Kirby
    Aug 26, 2016 at 19:08
  • is /etc/X11/xorg.conf.d/ dir used on Ubuntu? Sep 2, 2016 at 17:05
  • 7
    I think dir for Ubuntu should be /usr/share/X11/xorg.conf.d/ Oct 20, 2016 at 19:17
  • 1
    You should create the /etc/X11/xorg.conf.d/ directory first if it does not exist. /usr/share/X11/xorg.conf.d/ is there for system vendor options and not for custom user configuration. Read "man xorg.conf" for details.
    – zeehio
    Jul 20, 2018 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.