6

It seems I've lost some of my mouse and touchpad settings:

mouse touchpad settings problem ubuntu 16.04

As it is, I can move the pointer with the touchpad, but there's no tap-to-click and it's set to non-natural two-finger scrolling.

So far, I've tried uninstalling/installing Synaptics touchpad driver, but no luck with that.

Does anyone know how can I get scrolling and click options back?

  • In ubuntu 16.04 LTS touchpad worked and Fn+F9 could enable/disable touchpad and I saw touchpad settings in "Mouse & Touchpad". Recently I switched to ubuntu Gnome 16.04 LTS and I faced with the same issue. I solved this by installing missing packages sudo apt install xserver-xorg-input-libinput xorg-input-abi-22 xserver-xorg-core from this answer askubuntu.com/a/778766/542791 – Alexey Volodko Sep 9 '17 at 17:13
1

Alright, so I found a solution to my issue here, but here's a more concise explanation of what actually solved my issue:

Basically, I had to go to /usr/shar/X11/xorg.conf.d and edit the 50-synaptics.conf file. Assuming root privileges, I opened this file in nano and added the following three lines under the third stanza, right below any already-listed Option:

Option "VertEdgeScroll" "1"
Option "TapButton2" "2"
Option "TapButton3" "3"

I then saved this as 90-synaptics.conf and removed any competing libinput files. Rebooted, and got back tap-to-click, two-fingered right click, and edge scrolling (both vertical AND horizontal); exactly the same setup I had before.

From the Mouse and Touchpad settings menu, I regained everything but the ability to turn on/off horizontal scrolling.

0

I had the same problem on 19.10. It turned out that I didn't have the package xserver-xorg-input-synaptics installed. It turns out is doesn't have a chain of dependency from ubuntu-desktop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.