So, I have one software that always asks for password when starting. And I want to run this software without this gksu password prompt popping up everytime.

The first thing I tried was adding its path to sudoers. However, that didn't work. Later I found out there's a thing called policykit, and if some program wants to use some of policykit actions, it will always prompts user for password (sudoers have no effect on it).

I followed a guide in How do I prevent PolicyKit from asking for a password?, but it still doesn't work, so I think I might have added wrong action.

Question: How I can see what pkaction does my program use so I can enter it in my .pkla file?

  • Which software in particular do you want to run like this? What exactly did you try to achieve that and what happened instead? Did you encounter any warning or error messages? Please reproduce them in their entirety in your question. You can select, copy and paste terminal content and most dialogue messages in Ubuntu. (see How do I ask a good question?) Feb 24, 2017 at 10:55

2 Answers 2


Ask Ubuntu has this answer (How to configure pkexec to not ask for password?) that is closer to what you need than the link you found earlier.

As a quick example to finding the application, I'll illustrate using my own script. I wanted to replace gksu which is being deprecated with pkexec so I wrote a wrapper script called gsu.

I invoke gsu from the command line with:

gsu pkexec

Notice the Details drop down arrow. Click it and this is revealed:

gsu pkexec details

In my example the pkla is controlled by org.gnome.gedit. I'll use that in the next example, which you would replace with your own:

gsu pexec authorities

If you want to run without password prompt you would set the following:


On a personal note I don't like repeatedly entering the password myself but will not change gedit to never ask for password when changing root files using pkexec. However I would like it to not repeatedly ask for password when running it many times in given session. You can do this with sudo and you can extend the period from 10 minutes to 120 minutes as I have done on my system. I would like similar functionality for policy kits.

  • There are cases where no prompt is made: askubuntu.com/a/884708/158442
    – muru
    Feb 26, 2017 at 3:30
  • @muru You wrote an excellent answer there and only got one upvote while Byte Commander got 16 upvotes for the question. Deviation from normal Q&A voting. +1 for the answer there but would you like me to put your link into my answer too? Feb 26, 2017 at 17:47
  • 1
    no, but I'd like to know how to find the action when there is no prompt. In that case, I knew beforehand the actions used by shutdown, restart, etc., but they have changed before and may change again.
    – muru
    Feb 27, 2017 at 0:19

It would seem counter-intuitive to bypass the security of a policykit authorization. In the absence of any further details my best advice is don't do it.

Be that as it may,

A mechanism needs to declare a set of actions in order to use polkit. Actions correspond to operations that clients can request the mechanism to carry out and are defined in files that the mechanism installs into the /usr/share/polkit-1/actions directory.

pkaction --verbose

will produce detailed output regarding all policykit actions. This will be useful when reviewing local config files. You can redirect this output to a text file for later review in the usual way >later.review.txt

These config files are found in the directories listed when you issue the command sudo ls /var/lib/polkit-1/localauthority/

10-vendor.d  20-org.d  30-site.d  50-local.d  90-mandatory.d

dig around and find the .pkla file that corresponds to your unidentified software. Absent any useful information I'll pretend it's the Unity Greeter for example. We can review the lines that begin with Action= with the command sudo grep "Action=" /var/lib/polkit-1/localauthority/10-vendor.d/unity-greeter.pkla Which results in


For further information the latest polkit reference manual can be found here and related information on systemd can be found here

As @muru points out there's also a related Q&A here



How do I prevent PolicyKit from asking for a password?

  • Of course, this needn't always be about bypassing security, but could be the other way around: askubuntu.com/a/884708/158442 and best I can tell, systemd doesn't have a file in 10-vendor.d
    – muru
    Feb 26, 2017 at 3:29
  • @muru, good point regarding the bypass of security. I suppose the OP's statement regarding wanting to bypass the password led me to the conclusion that that was the intent. The 10-vendor.d is an example from one of my systems running the Unity desktop.
    – Elder Geek
    Feb 26, 2017 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.