9

I'm new to Linux, so I hope I'll be giving you helpful info here. On my last (recently deceased) laptop, I was running Ubuntu 14.04, and on that system my bluetooth Sony MDR-ZX770BT stereo headphones worked beautifully.

Now I have a brand new Lenovo G50-70 64-bit notebook with Ubuntu 16.04 preinstalled. The audio device is Haswell-ULT HD Audio Controller by Intel.

The headphones work now, but only in mono. When I look at sound settings, and check sound there, it tells me the sound is mono. Mono sound is coming through both sides of the headphone. I also think the built-in speakers are putting out mono, the sound is not good at all.

I've installed both blueman and pulseaudio controller. While pulseaudio will allow me to try both modes (headset and A2DP sink), blueman tells me that only headset mode will work, and the error message I get in blueman is "failed to change profile to a2dp_sink".

I've googled and checked here and can't find anything concerning this specific problem. It doesn't help that I'm ignorant of audio matters. I brought up alsamixer in the terminal, but don't understand what I'm looking at.

I'll be happy to post any logs once I know how to get to them.

Thank you in advance for any help you can give.

17

I solve my mono headphone problem that comes out after upgrading from 14.04 to 16.04

open terminal and start bluetooth controller sequence

$ bluetoothctl

Now the environmet intermenal should be changed to [bluetooth]# there is list of devices with MAC address and one of them should be your headphone. Connect device with its mac adress like

[bluetooth]# connect AA:BB:CC:DD:EE:FF

Your device now connected to your bluetooth device. Now where magic happens. Open another terminal and start the bluetooth device:

$ sudo service bluetooth restart

Now return to the tab with the environment [bluetooth]# Your device is disconnected after restarting bluetooth. Connect it again: [bluetooth]# connect AA:BB:CC:DD:EE:FF

Ta Da! This solves my problem. You can chach from sound settings That Your headset profile is set on High Fidelity Playback(A2DP Sink)

  • Thanks this worked great (when the highest voted answer didn't, because I didn't have a "High Fidelity Playback" option to select). – machineghost Jul 13 '18 at 20:24
  • Worked like a charm for me too. Now listening to Pandora in stereo on my Bose QC35 - soo much better! Thanks. – Reid Spencer Oct 1 '18 at 19:30
  • Thank you so much! Finally all my bluetooth problems have been solved :D – Jesse Busman Nov 30 '18 at 10:33
  • Can still confirm on "No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 18.04.1 LTS Release: 18.04 Codename: bionic" – Christopher Will Dec 7 '18 at 22:20
  • This should be the validated answer. Did the trick for me too – Cécile Fecherolle Mar 25 at 15:19
1

If your headset supports STEREO, you can change the settings at SOUND PREFERENCES.

(Assuming you successfully connected your BT headset)

  1. Go to System-Preferences-Sound
  2. Click HARDWARE Tab. You should see your Bluetooth headset here.
  3. Select Your Bluetooth headset
  4. At the lower part of the Hardware tab, Select "High Fidelity Playback (A2DP)

You should have STEREO sound now.

Good luck.

  • This is great advice, if there is a "High Fidelity Playback" option. But if you're like me, and that option was there yesterday, but is now gone and the only options are "Headset Head Unit (HSP/HFP)" and "Off" it doesn't help. – machineghost Jul 13 '18 at 20:21
0

There is an existing work around that you can find here.

The description is for KDE, but it can easily be adapted to unity. It feels like it might not work it takes a couple tries to get the right connect/disconnect and change profile sequence.

Hope it helps.

Pat

  • 1
    I tried that a couple of days ago. No dice. I also updated the RTL8723BE bluetooth driver in hopes that would work. Nope. I have a conversation ongoing at ubuntuforums.org, but folks are stumped. I submitted a bug report yesterday. It was kind of you to respond!! – Kate W. Aug 30 '16 at 3:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.