4

I have Kubuntu 16.04 installed. My recollection is that automatic spell checking was working fine under Kubuntu 14.04, with all the misspelled words it found underlined. But now since I've upgraded, it doesn't...

Under the Configure-Kate-dialog, I have selected a bright red line for Fonts & Colors [colors tab] spelling mistake line so it should be visible. And under that dialogs Editing section, within the Spellcheck tab, I have selected [x]Automatic spell checking enable by default, to no avail. And I've tried toggling on and off this other option under the spellcheck tab [x]Automatic spell checking enabled by default, and [x]Enable auto-detection of language, to no avail.

Outside of the configure-kate-dialog, under the main menu's TOOLS>spelling> [x]automatic spell checking has been toggled on and off, to no avail. Any ideas what's going on?

==ADDED INFORMATION==

apt-cache policy aspell:

aspell:
  Installed: 0.60.7~20110707-3build1
  Candidate: 0.60.7~20110707-3build1
  Version table:
 *** 0.60.7~20110707-3build1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64
  • 1
    It's working here in 16.04. Can you give the output of apt-cache policy aspell? – Anwar Sep 6 '16 at 6:56
  • aspell: Installed: 0.60.7~20110707-3build1 Candidate: 0.60.7~20110707-3build1 Version table: *** 0.60.7~20110707-3build1 500 500 us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages 100 /var/lib/dpkg/status – user12711 Sep 7 '16 at 16:45
3

I found several reports of this bug. Listing here, here and here.

However, there is a workaround. You need to disable Enable autodetection of language from Settings -> Configure Kate -> Editing -> Spellcheck tab.

Then it will detect the error if you go to Tools -> Spelling -> Spelling. But auto-detection doesn't work sometimes. You can make this menu a shortcut by using Settings -> Configure Shortcuts menu.

  • That's almost as good. – user12711 Sep 12 '16 at 20:47
1

Coherent howto for the example of the German language:

(because English might benefit ftom specific default preferences)

(1) ++"Settings" ... ++"Configure Kate" ... ++"Fonts & Colors" ...

goto headline: "Text decoration" ... --- goto sub-line: "spelling mistake line"

--- select a typical color like "dark red"

(2) ++"Settings" ... ++"Configure Kate" ... ++"Editing" ... ++"Spellcheck"

in "Standard language" (DE "Standardsprache") select: ++"German (Germany)" (DE : "Deutsch (Deutschland)"

=== === and now the most important setting: === ===

set to "OFF": "automatic language detection" (DE : "Automatische Erkennung der Sprache")

This is the setting which creates all the trouble. "Automatic" sounda good but then spellchecking does not work - a bug.

(3) The 3 following feature options: (Capitals etc.): ... you might set them all to: "ON"

(4) ++"Apply" ... ++"ok"

(5) back into the editor / file to edit: ++"Tools" ... ++"Spelling" ....

and there: ++"Automatic Spelling"

(6) change the language: ++"Tools" ... ++"Spelling" ...: ++"Change Dictionary"

Result: on the bottom of the KATE window - search field - will appear the option selector.

You can opt for any language available on your PC.

(7) Hopeful that you will be successful, too. (done on UBUNTU 16.4 )

(Improvement suggestions if any, especially for languages DE FR ES EN , please to the email address: ok Q infos7.com )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.