1

My system takes ages to boot, especially to log in. I'm not sure how I should go about the problem - I can't use Ubuntu like that.

  • Here are the relevant parts from dmesg -d:

    [   15.997008 <    2.347582>] Adding 16062460k swap on /dev/sdc5.  Priority:-1 extents:1 across:16062460k FS
    [   20.466801 <    4.469793>] IPv6: ADDRCONF(NETDEV_UP): wlx74da387e95a8: link is not ready
    [   20.478821 <    0.012020>] IPv6: ADDRCONF(NETDEV_UP): wlx74da387e95a8: link is not ready
    [   21.020986 <    0.542165>] IPv6: ADDRCONF(NETDEV_UP): wlx74da387e95a8: link is not ready
    [   37.437661 <   16.416675>] wlx74da387e95a8: authenticate with e8:74:e6:09:de:69
    

    and

    [  112.496226 <   75.016139>] usb 1-1.3: rtl8xxxu_ampdu_action: IEEE80211_AMPDU_RX_START
    

    The latter is the driver of my Wirelesss stick, the Edimax EW-7811Un running on RTL8188Cu. The driver isn't original, I had to manually install it and replace the original one in order for the stick to work properly.

  • Here's my systemd plot:

    systemd plot

    • Time my system needs for startup, measured with a phone:

      • 30s for bootup, as indicated in the bootchart
      • 2 minutes 10 seconds for login and opening of terminal using Ctrl+Alt+T
    • Maybe there is a problem with my harddrive - or my /home partition specifically. When logging in, Ubuntu behaves as if the loading process was very slow: I first see my background for a long time, then unity appears but is unreactive for a bit - then my launcher takes a while to load and finally the first application I launch takes a while as well. After that everything works with quite a decent speed though, as if it cached the files - I don't know enough about Linux to speculate about that though. Notice that the mounting of my /home-partition takes up most of the time of the booting process by far.

      About my file system: My root is an 500GB Ext4 partition. I then have a sepearte NTSF partition on the same harddrive for the /home directory. Root, /home and Swap are all on the same harddrive.

    • I created a new account to see if it takes a long time to log in as well. It doesn't. Neither does logging in from the virtual terminals.
    • Resetting unity using dconf reset -f /org/compiz and then setsid unity doesn't change anything either.
  • Oh well, looks like I'll have to switch to Fedora... – Nearoo Sep 6 '16 at 12:57
  • +David Foerster Ok, thanks for the tip. But you know, I'm a bit tired with ubuntu. I tried to do what you said. First I couldn't install it because the folder was locked, so I had to google the error message to see what the problem was: My system was currently updating itself. Cool, wait a bit until it's done. Finally it worked. So I rebooted, but the bootchart folder was empty. Again, google the problem: A bug. bugs.launchpad.net/ubuntu/+source/bootchart/+bug/1458170 Well, 15 minutes wasted. Nice. Windows it is, again... – Nearoo Oct 8 '16 at 10:54
  • @DavidFoerster Alright, did that: askubuntu.com/questions/834529/… Though I think people would've already written a solution to that problem in this post. Thanks for your help. – Nearoo Oct 8 '16 at 11:12
  • @DavidFoerster No problem. At least I have a bootchart now. I updated my question. – Nearoo Oct 8 '16 at 12:10
  • @DavidFoerster I wrote "My system takes ages to boot, especially to log in." I have actually just measured the time for both processes. Boot time takes about 30 seconds, as indicated in boot chart. But after I login I have to wait 2:10 minutes until I can use it. Seems like the bootchart isn't actually that useful, sadly. (Dmesg displays messages until after the login process, right?). – Nearoo Oct 8 '16 at 13:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.