I have a problem with chrome performance. When i have two or more chrome windows, and one of them containing playing video (youtube) - then every other chrome window become jerky and not smooth at page scrolling or playing CSS animations (low FPS).

Here is screenshot of chrome task manager at the moment of scrolling: chrome with task manager

As you can see, GPU process is taking too much CPU resources.

I also noticed that dragging any window on top of chrome window (with playing youtube video) is not smooth too. Very annoying.

I tried to run chrome with --disable-gpu-vsync key and scrolling became smooth, but any CSS animation used 100% of one CPU core for max FPS.

With disabled vsync in nvidia-settings/ccsm has same effect, even with disabled composite.

So i dont know what to do. Firefox has not such problems, but i dont want to switch.

Output of chrome://gpu

Graphics Feature Status
Canvas: Software only, hardware acceleration unavailable
Flash: Hardware accelerated
Flash Stage3D: Hardware accelerated
Flash Stage3D Baseline profile: Hardware accelerated
Compositing: Hardware accelerated
Multiple Raster Threads: Enabled
Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
Rasterization: Software only. Hardware acceleration disabled
Video Decode: Software only, hardware acceleration unavailable
Video Encode: Hardware accelerated
WebGL: Hardware accelerated
Driver Bug Workarounds
Problems Detected
Accelerated 2d canvas is unstable in Linux at the moment
Disabled Features: accelerated_2d_canvas
Accelerated video decode is unavailable on Linux: 137247
Disabled Features: accelerated_video_decode
Always call glUseProgram after a successful link to avoid a driver bug: 349137
Applied Workarounds: use_current_program_after_successful_link
Program link fails in NVIDIA Linux if gl_Position is not set: 286468
Applied Workarounds: init_gl_position_in_vertex_shader
Clear uniforms before first program use on all platforms: 124764, 349137
Applied Workarounds: clear_uniforms_before_first_program_use
Linux NVIDIA drivers don't have the correct defaults for vertex attributes: 351528
Applied Workarounds: init_vertex_attributes
Always rewrite vec/mat constructors to be consistent: 398694
Applied Workarounds: scalarize_vec_and_mat_constructor_args
MakeCurrent is slow on Linux with NVIDIA drivers
Applied Workarounds: use_virtualized_gl_contexts
NVIDIA fails glReadPixels from incomplete cube map texture: 518889
Applied Workarounds: force_cube_complete
Pack parameters work incorrectly with pack buffer bound: 563714
Applied Workarounds: pack_parameters_workaround_with_pack_buffer
Alignment works incorrectly with unpack buffer bound: 563714
Applied Workarounds: unpack_alignment_workaround_with_unpack_buffer
Accelerated rasterization has been disabled, either via about:flags or command line.
Disabled Features: rasterization

My pc configuration:
i7 6700k
Nvidia GTX1080 with latest nvidia driver-370
Ubuntu 16.04 / latest chrome/chromium (tried both)


This issue reproducing on other linux distributions with different DEs and composite managers. And not only for me.

So most probably problem in nvidia drivers for gtx10xx cards.



  • Did you try disabling hardware acceleration in Chrome? – edwinksl Sep 3 '16 at 21:02
  • @edwinksl, yes. Gpu process has gone, but vsync tearing started to annoying me :) – Vovan Sep 3 '16 at 21:12
  • I have the same. Did you solve the issue ? – wwvv Dec 27 '16 at 15:10
  • @wwvv, no. I tried other linux distros - but result is always same. – Vovan Dec 27 '16 at 15:48

nVidia is known for poor support on Linux I guess. Try using integrated graphics for chrome and the nvidia for other stuff. I cant even find appropiate drivers for my 760m where I can control which gpu to switch + basic power control.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.