0

I am currently using ubuntu 16.04. When I am using applications, such as Kile, to open documents I have to use ubuntu's default file manager. Right now I have Krusader installed(my choice of file manager).

How can I make it so that all applications (including Kile) use Krusader to open files?

1

Well Open terminal and install exo-utils

sudo apt-get install exo-utils

Now run the following command in terminal

exo-preferred-applications

Under Utilies Tab you will have File Manager to choose.

If you are using Xubuntu distros then go to
Settings Manager > Preferred Applications > Utilities , there you have the dropdown option to select the File Managers you already installed.


if above things fails then try running following command in a new terminal.

xdg-mime default Krusader.desktop inode/directory application/x-gnome-saved-search
| improve this answer | |
  • Thanks for the quick response. However, I tried this solution and it did not work. When I click on the tabs in the Preferred Application window I get this error "(exo-helper-1:20840): Gdk-CRITICAL **: IA__gdk_window_get_window_type: assertion 'GDK_IS_WINDOW (window)' failed" . Also tried the las line and nothing happen. – dowewas Aug 25 '16 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.