5

I recently installed Ubuntu in a VM on Windows 10 and have the problem that videos just don't want to play. Youtube and other websites don't work. Not even downloading the videos and playing them with the default player doesn't work. Installing VLC fixed the problem with downloaded videos but videos in Firefox / Chrome still don't work. I have another Ubuntu VM (which I currently can't access because it's encrypted) where everything seems to work just fine. There's no error or anything popping up when I try to watch a video just the first frame in a static picture.

Things I tried that didn't fix the problem:

  • Rebooting

  • Using the commandsudo apt-get install ubuntu-restricted-extras to install codecs

  • Rebooting after that

  • Installing Chrome

  • Rebooting again

  • Updating all software

  • And again rebooting

The only solution I can find is to install the restricted extras which doesn't fix the problem for me. Thanks in advance!

  • You don't say what kind of Virtualization Software you use. Tools like VMWare Workstation and VirtualBox have so called "Guest Tools". Basically, some kind of drivers for the virtual machine, so it interacts better with the host machine (your Windows 10). I'd suggest that you start off looking whether such a thing exists for your virtualization solution. – jawtheshark Aug 25 '16 at 16:00
  • Hello first off thanks for the answer! I added it in the tags but totally forgot to mention that I'm using virtualbox. The Guest Tools are already installed so that's not it either. – EgoNecoTu Aug 25 '16 at 16:56
7

I found a solution for this a few weeks ago somewhere and it worked for me. I realized the videos don't play on the VM because of the audio settings (and not any video settings).

  1. Shut down the VM (in my case Ubuntu 16.04.1).
  2. In VirtualBox, click "Settings".
  3. Go to the "Audio" section and change the "Audio Controller" from the default to the other available option ("Intel HD Audio" controller was my 2nd option).
  4. Start the Virtual Machine and see if this work.
  • 1
    Yea this was it, found the solution trough trial and error too. Forgot to update the post though thanks for the answer! – EgoNecoTu Sep 13 '16 at 18:00
  • Does not work for me. – Calmarius Feb 7 '17 at 14:17
0

Enabling 3D acceleration in the VM display settings fixed it for me.

0

Old thread, but in case someone else stumbles across this. I already had the above proposed solutions set on my system. What resolved this for me was going into the VirtualBox VM settings > Network > Advanced and change the Adapter Type to "Paravirtualized Network (virtio-net)." So maybe it's a combination of some/all of these suggestions.

0

This was so annoying for me as the video would load and buffer but not play.

  • Virtualbox Version 6.0.12 r133076 (Qt5.6.2)
  • Ubuntu version 19 Dancing Dingo.
  • Audio ICH AC97 (default)
  • Video no acceleration (default)

[Default audio settings][1] [![enter image description here][1]][1]

[Default display settings][2] [![enter image description here][2]][2] Then I tried the above advice above

  • Audio setting changed to HD Audio

This did not fix playback stuck problem.

Then I tried the above advice above

  • Video 3D Acceleration was changed to check / enable

This did fix playback stuck problem. Then I reverted the settings to prove it was the proper fix, and for a while it did work without the changes. Then it stopped working again. So there are some side-effects happening.

In the end, it seems the changes are required for Ubuntu 19 but not Ubuntu 18.

Sorry for any confusion.
Thankfully it is now working for Ubuntu 19, Dancing Dingo. Cheers :)

  • The screenshots are missing. – kiamlaluno Nov 5 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.