What I do:
I prepare Ubuntu live USB and boot with it. I select the USB pen drive. The PC tries to boot from it.
What happens
I receive an error message: boot error.
What is expected:
A normal boot procedure.
Some other information:
1) No matter how I prepare the USB, I get the same result. The USB works just fine on some other PC.
2) The PC will boot from USB made to boot MS-DOS.
3) The PC is dual-boot, Win7 and Ubuntu(installed from CD)
4) The BIOS is Phoenix-Award(version of bios dated 2008), the motherboard is comparatively new.

  • can you post the complete error message please – VENKI Nov 22 '11 at 14:21
  • That is all: <br/> "Verifying DMI Pool Data ....... Update Success" " <br/> "Boot Error". These are all messages I got - no Ubuntu menu, noting. Tried installing mbr and formatting the drive to zip drive format. Not quite sure I succeeded with the last two. – deckoff Nov 22 '11 at 14:51
  • I tried bypassing BIOS (I suspect) limitations with plop LiveCD, but still boot fails... – deckoff Nov 27 '11 at 17:58
  • I have a computer that refuses to boot off a certain flash drive, even though I can boot with other flash drives, or even use the same flash drive to boot off other computers. I would suggest trying a different flash drive if you have one available, if not you can get a cheap SanDisk (which I have had really good luck with) or you can try booting a LiveCD, perhaps it isn't the flash drive at all. Also, what kind of flash drive is it? – TheXed Dec 2 '11 at 19:57
  • Which Ubuntu version(s)? on the PC (dual boot), and on USB (Live CD) attempting boot .. – david6 Dec 2 '11 at 20:01

change usb drive from zip to hd and set it to first boot device.

|improve this answer|||||
  • I think this worked, though I fixed it a while ago. I will accept the answer, even though I am not quite sure if this fixed the issue, this is a valid answer similar problems. I learnt a few thinks for these 2 years – deckoff Oct 7 '13 at 18:11

This worked for me. i think the BIOS is to blame. Award-Phoenix 6.00PG. 1) I create DOS bootable USB. Simply dd the iso found here This will be called DOS-USB

After doing this, the DOS-USB is seen as harddrive by the bios, not as usb 2) Download grub4dos and extract grub.exe from the zip and copy it in the root of the DOS-USB. GRUB4DOS download 3)Create file menu.lst(or copy the one from the zip) and add this:

title Boot MultiBOOT LinuxUSB
find --set-root /boot/bootme.tag
kernel /boot/grub/core.img

(this entry assumes there is a file called bootme.tag in boot of your second, booting USB.You should create this one yourself. It is added as id file, since I assume most of you have Ubuntu installed, so searching for GRUB file will find two drives)

4) Create your booting USB(you need 2 USB for this solution) I call it Linux-USB. I use this tool but any GRUB2-based tool should work. MultisystemUSB though fails. I have not tried Unetbootin and Ubuntu Live USB

5) Create an Non-empty(some text will do) file, call it bootme.tag and copy it to /boot of your Linux-USB. Reboot with both USBs plugged, select to booth from DOS-USB. When you see c:, enter grub.exe, and select Boot MultiBOOT LinuxUSB entry. This should find and boot the Linux-USB.

|improve this answer|||||

With Award BIOS 6.00PG I had the same problem, but it is entirely BIOS related. The way to do it is:

  1. insert USB with live system
  2. start machine and enter BIOS (del key)
  3. select "Advanced Boot Parameters", in which the USB key should now be listed
  4. move USB key to top of boot order
  5. save and exit
  6. let machine reboot -- it will use the USB key to boot that one time.
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.