I want to connect to our company VPN.

I found guide on official Ubuntu documentation but that is not valid for Kubuntu or KDE desktop environment.

Is there alternative way to do this on Kubuntu or via terminal?

  • What guide you followed that's not for Kubuntu? Have you tred openvpn? – Anwar Aug 25 '16 at 9:53
  • Is your company using PPTP or openVpn? The instructions should come from the company in these cases. – Anwar Aug 25 '16 at 9:56
  • @Anwar They all use Windows OS, they only provided me with credentials – Kunok Aug 25 '16 at 9:57
  • You need to know which type of VPN clients you find an accurate answer. Or which equivalent windows software they use? – Anwar Aug 25 '16 at 10:04
up vote 1 down vote accepted

Connecting to PPTP VPN in Kubuntu 16.04 is easy. Follow the procedure:

  1. Click on the Network Manager Icon on the Panel

    Network Icon

    If you can't find that icon, install plasma-nm package.

    sudo apt-get install plasma-nm
    

    and add the widget to the panel

  2. In the Opened Pop-Up notification, click on the Settings Icon at the right side.

    Settings Icon

  3. On the New Connection Editor window, Click on the Add button and select Point-to-Point Tunneling Protocol from the dropdown menu.

    pptp

  4. On the New Connection (vpn) window, provide the vpn address in the Gateway field, fill username and password and click OK to save. You can leave NT Domain field empty.

Now you can connect to the VPN from the Network Manager Widget.

From OPs feedback, it seems you need to click on Advanced tab in Create new connection window and enable the option for USE MPPE Encryption option to be enable to use with Windows VPN.

Check the screenshot below for that

special settings for windows vpn

  • I get connection stopped error. On Win10 same credentials work. – Kunok Oct 23 '16 at 13:41
  • @Kunok did you follow the exact procedure? – Anwar Oct 23 '16 at 15:41
  • Ok, I just want to add that if you are connecting to windows VPN then you need to configure some settings first in Advanaced. See screenshot: i.imgur.com/39uWX80.png and then connection works. – Kunok Oct 23 '16 at 16:25
  • @Kunok thank you for the feedback. I've included that information in the answer – Anwar Oct 23 '16 at 16:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.