0

After upgrading to Ubuntu 16.04 (removing the package virtualbox-qt which had dependency problems), apt-get autoremove wants to remove those packages:

account-plugin-twitter automake1.4 checkbox-ng dh-apparmor friends friends-dispatcher friends-facebook friends-twitter g++-4.8 gcc-4.8-base:i386 gcc-4.9-base gcc-4.9-base:i386 gir1.2-ebook-1.2 gir1.2-ebookcontacts-1.2 gir1.2-edataserver-1.2 gir1.2-gnomebluetooth-1.0 gir1.2-messagingmenu-1.0 gir1.2-networkmanager-1.0 gnome-desktop-data gnome-themes-standard gnome-themes-standard-data gstreamer0.10-nice gstreamer0.10-plugins-bad gstreamer1.0-clutter gtk2-engines-pixbuf gtk3-engines-unico libapt-inst1.5 libarchive-extract-perl libatk-wrapper-java libatk-wrapper-java-jni libbaloocore4 libbaloofiles4 libbalooxapian4 libbasicusageenvironment0 libbind9-90 libbit-vector-perl libboost-date-time1.54.0 libboost-filesystem1.54.0 libboost-iostreams1.54.0 libboost-signals1.54.0 libboost-system1.54.0 libboost-thread1.54.0 libcamel-1.2-45 libcarp-clan-perl libcdr-0.0-0 libcgmanager0:i386 libclamav6 libcmis-0.4-4 libcolamd2.8.0 libcolord1 libcolord1:i386 libcolorhug1 libcommons-lang-java libconfig++9 libcrypt-passwdmd5-perl libdate-calc-perl libdate-calc-xs-perl libdevmapper-event1.02.1 libdirac-encoder0 libdns100 libdvbpsi8 libebackend-1.2-7 libebook-1.2-14 libebook-contacts-1.2-0 libedata-book-1.2-20 libedataserver-1.2-18 libegl1-mesa-drivers libelfg0 libept1.4.12 libepub0 libexiv2-12 libfarstream-0.1-0 libfriends0 libgconf2-4 libgdata13 libgdome2-0 libgdome2-cpp-smart0v5 libgee2 libgif4 libgif4:i386 libglamor0 libglew1.10 libglewmx1.10 libgnome-bluetooth11 libgnome-desktop-3-7 libgrip0 libgroupsock1 libgsoap4 libgsoap8 libgstreamer-plugins-bad0.10-0 libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386 libgtkmathview0c2a libgtop2-7 libicc2 libicu48 libicu4j-4.4-java libicu52 libidl-2-0 libidl-common libimdi0 libimobiledevice4 libisc95 libisccc90 libisccfg90 libisl10 libjasper1:i386 libjs-codemirror libjs-jquery-cookie libjs-jquery-event-drag libjs-jquery-metadata libjs-jquery-mousewheel libjs-jquery-tablesorter libjs-jquery-ui libjson0 libjson0:i386 libkactivities-models1 libkidletime4 liblinear1 liblivemedia23 libllvm3.4:i386 libllvm3.4 liblog-message-perl liblog-message-simple-perl liblouis2 liblvm2app2.2 liblwres90 libmagickcore5 libmagickcore5-extra libmagickwand5 libmbim-glib0 libmikmod2 libminiupnpc8 libmspub-0.0-0 libmysqlclient18:i386 libnepomukcleaner4 libnepomukcore4abi1 libnih-dbus1:i386 libnih1:i386 libopenobex2 libopenvg1-mesa liborbit2 liborcus-0.6-0 libparted0debian1 libplist1 libpocketsphinx1 libpod-latex-perl libpoppler-qt4-4 libpoppler44 libpostproc52 libprocps3 libprotobuf8 libqca2-plugin-ossl libqjson0 libqmi-glib0 libqmobipocket1 libqpdf13 libqt5qml-graphicaleffects libqt5sensors5 libqt5webkit5-qmlwebkitplugin libraw9 libreadline5 librhythmbox-core8 librtaudio4 librtmidi1 libservlet2.5-java libslv2-9 libsoprano4 libsoundtouch0 libsphinxbase1 libstk0c2a libsystemd-daemon0 libsystemd-journal0 libsystemd-login0 libt1-5 libtar0 libterm-ui-perl libtext-soundex-perl libthumbnailer0 libtorrent-rasterbar7 libts-0.0-0 libunityvoice1 libupower-glib1 libusageenvironment1 libusbmuxd2 libvisio-0.0-0 libvncserver1 libvpx1:i386 libwnck-common libwnck22 libwpd-0.9-9 libwpg-0.2-2 libwps-0.2-2 libxcb-util0 libxen-4.4 libxerces2-java libxml-commons-external-java libxtables10 libzip2 libzip4 m17n-contrib nepomuk-core-data obex-data-server php5-gd python-commandnotfound python-dbus-dev python-gconf python-gdbm python-gnomekeyring python-ibus python-libxml2 python-pexpect python-ptyprocess python-renderpm python-reportlab python-reportlab-accel python-smbc python-support python-wxgtk2.8 python3-checkbox-ng qml-module-qtquick-localstorage qml-module-ubuntu-ui-extras-browser qtdeclarative5-dialogs-plugin qtdeclarative5-localstorage-plugin qtdeclarative5-privatewidgets-plugin qtdeclarative5-qtfeedback-plugin qtdeclarative5-ubuntu-ui-extras-browser-plugin qtdeclarative5-ubuntu-ui-extras-browser-plugin-assets qtdeclarative5-window-plugin rhythmbox-mozilla shared-desktop-ontologies soprano-daemon sphinx-voxforge-hmm-en sphinx-voxforge-lm-en telepathy-indicator tsconf ttf-freefont ubuntu-extras-keyring udisks unity-lens-friends unity-scope-audacious unity-scope-clementine unity-scope-gmusicbrowser unity-scope-gourmet unity-scope-guayadeque unity-scope-musique unity-voice-service virtualbox-dkms xfonts-mathml

Here is a more human-friendly version:

account-plugin-twitter automake1.4 checkbox-ng dh-apparmor friends
friends-dispatcher friends-facebook friends-twitter g++-4.8 gcc-4.8-base:i386
gcc-4.9-base gcc-4.9-base:i386 gir1.2-ebook-1.2 gir1.2-ebookcontacts-1.2
gir1.2-edataserver-1.2 gir1.2-gnomebluetooth-1.0 gir1.2-messagingmenu-1.0
gir1.2-networkmanager-1.0 gnome-desktop-data gnome-themes-standard
gnome-themes-standard-data gstreamer0.10-nice gstreamer0.10-plugins-bad
gstreamer1.0-clutter gtk2-engines-pixbuf gtk3-engines-unico libapt-inst1.5
libarchive-extract-perl libatk-wrapper-java libatk-wrapper-java-jni
libbaloocore4 libbaloofiles4 libbalooxapian4 libbasicusageenvironment0
libbind9-90 libbit-vector-perl libboost-date-time1.54.0
libboost-filesystem1.54.0 libboost-iostreams1.54.0 libboost-signals1.54.0
libboost-system1.54.0 libboost-thread1.54.0 libcamel-1.2-45 libcarp-clan-perl
libcdr-0.0-0 libcgmanager0:i386 libclamav6 libcmis-0.4-4 libcolamd2.8.0
libcolord1 libcolord1:i386 libcolorhug1 libcommons-lang-java libconfig++9
libcrypt-passwdmd5-perl libdate-calc-perl libdate-calc-xs-perl
libdevmapper-event1.02.1 libdirac-encoder0 libdns100 libdvbpsi8
libebackend-1.2-7 libebook-1.2-14 libebook-contacts-1.2-0 libedata-book-1.2-20
libedataserver-1.2-18 libegl1-mesa-drivers libelfg0 libept1.4.12 libepub0
libexiv2-12 libfarstream-0.1-0 libfriends0 libgconf2-4 libgdata13 libgdome2-0
libgdome2-cpp-smart0v5 libgee2 libgif4 libgif4:i386 libglamor0 libglew1.10
libglewmx1.10 libgnome-bluetooth11 libgnome-desktop-3-7 libgrip0 libgroupsock1
libgsoap4 libgsoap8 libgstreamer-plugins-bad0.10-0
libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386
libgtkmathview0c2a libgtop2-7 libicc2 libicu48 libicu4j-4.4-java
libicu52 libidl-2-0 libidl-common libimdi0 libimobiledevice4 libisc95
libisccc90 libisccfg90 libisl10 libjasper1:i386 libjs-codemirror
libjs-jquery-cookie libjs-jquery-event-drag libjs-jquery-metadata
libjs-jquery-mousewheel libjs-jquery-tablesorter libjs-jquery-ui libjson0
libjson0:i386 libkactivities-models1 libkidletime4 liblinear1 liblivemedia23
libllvm3.4:i386 libllvm3.4 liblog-message-perl liblog-message-simple-perl
liblouis2 liblvm2app2.2 liblwres90 libmagickcore5 libmagickcore5-extra
libmagickwand5 libmbim-glib0 libmikmod2 libminiupnpc8 libmspub-0.0-0
libmysqlclient18:i386 libnepomukcleaner4 libnepomukcore4abi1 libnih-dbus1:i386
libnih1:i386 libopenobex2 libopenvg1-mesa liborbit2 liborcus-0.6-0
libparted0debian1 libplist1 libpocketsphinx1 libpod-latex-perl
libpoppler-qt4-4 libpoppler44 libpostproc52 libprocps3 libprotobuf8
libqca2-plugin-ossl libqjson0 libqmi-glib0 libqmobipocket1 libqpdf13
libqt5qml-graphicaleffects libqt5sensors5 libqt5webkit5-qmlwebkitplugin
libraw9 libreadline5 librhythmbox-core8 librtaudio4 librtmidi1
libservlet2.5-java libslv2-9 libsoprano4 libsoundtouch0 libsphinxbase1
libstk0c2a libsystemd-daemon0 libsystemd-journal0 libsystemd-login0 libt1-5
libtar0 libterm-ui-perl libtext-soundex-perl libthumbnailer0
libtorrent-rasterbar7 libts-0.0-0 libunityvoice1 libupower-glib1
libusageenvironment1 libusbmuxd2 libvisio-0.0-0 libvncserver1 libvpx1:i386
libwnck-common libwnck22 libwpd-0.9-9 libwpg-0.2-2 libwps-0.2-2 libxcb-util0
libxen-4.4 libxerces2-java libxml-commons-external-java libxtables10 libzip2
libzip4 m17n-contrib nepomuk-core-data obex-data-server php5-gd
python-commandnotfound python-dbus-dev python-gconf python-gdbm
python-gnomekeyring python-ibus python-libxml2 python-pexpect
python-ptyprocess python-renderpm python-reportlab python-reportlab-accel
python-smbc python-support python-wxgtk2.8 python3-checkbox-ng
qml-module-qtquick-localstorage qml-module-ubuntu-ui-extras-browser
qtdeclarative5-dialogs-plugin qtdeclarative5-localstorage-plugin
qtdeclarative5-privatewidgets-plugin qtdeclarative5-qtfeedback-plugin
qtdeclarative5-ubuntu-ui-extras-browser-plugin
qtdeclarative5-ubuntu-ui-extras-browser-plugin-assets
qtdeclarative5-window-plugin rhythmbox-mozilla shared-desktop-ontologies
soprano-daemon sphinx-voxforge-hmm-en sphinx-voxforge-lm-en
telepathy-indicator tsconf ttf-freefont ubuntu-extras-keyring udisks
unity-lens-friends unity-scope-audacious unity-scope-clementine
unity-scope-gmusicbrowser unity-scope-gourmet unity-scope-guayadeque
unity-scope-musique unity-voice-service virtualbox-dkms xfonts-mathml

I suspect dpkg --configure -a did the trouble.

How to answer

Please list the packages I need in your answer, don't just say that "some packages are needed". The list can have any of these three formats:

Spaces

pkg-1 pkg-2 pkg-3

Newlines

pkg-1
pkg-2
pkg-3

Mixed

pkg-1 pkg-2 package-name-with-length-that-will-cover-80-characters-right-now
pkg-3

Note: on "mixed" format, please add a newline every 80 characters or less. Do not separate package names with newlines. If the 80th character is not a space, replace the space right before the package name with a newline, like I did.

If there are any packages I need, I'll mark them as manually-installed (apt-get install pkg).

  • Please answer, I desparately need to auto-remove sometime... – EKons Aug 25 '16 at 8:33
  • Are you sure you need any of these? If so, why? – Jos Aug 25 '16 at 8:48
  • @Jos I'm not sure, that's why I'm asking. I can see names such as g++-4.8 that are needed AFAIK, although I'm not sure. – EKons Aug 25 '16 at 8:58
  • You can install aptitude and then run aptitude why g++-4.8 to see why a package was installed. Personally, I am not surprised at seeing hundreds of packages that may be auto-removed. I would just trust the package manager. You can always reinstall, of course. – Jos Aug 25 '16 at 9:07
  • @Jos I once had a serious problem on a virtual machine with autoremove, causing me to re-install the whole system. That's why I don't always trust the package manager. – EKons Aug 25 '16 at 9:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.