1

When I open a document in evince and read through some pages, close it and again reopen the same document in evince, it starts again from the first page. Even the bookmarks are not shown after reopening. Please help.

I read a lot of big books and its a nightmare to find where I was last time.

5
  • Which version of Ubuntu are you using?
    – Anwar
    Aug 28 '16 at 12:05
  • I'm using 16.04.
    – gabs1bb3
    Aug 29 '16 at 12:54
  • I'm using the same 16.04. but here evince automatically opens on the page I opened last. Can you run evince in a terminal and show us the output?
    – Anwar
    Aug 29 '16 at 12:55
  • when I wrote evince on the terminal and hit enter it showed the following message: (evince:12658): GVFS-WARNING **: can't init metadata tree /home/sanjeev/.local/share/gvfs-metadata/home: open: Permission denied (evince:12658): GVFS-WARNING **: can't init metadata tree /home/sanjeev/.local/share/gvfs-metadata/home: open: Permission denied (evince:12658): GVFS-WARNING **: can't init metadata tree /home/sanjeev/.local/share/gvfs-metadata/home: open: Permission denied
    – gabs1bb3
    Aug 29 '16 at 13:07
  • Check the answer
    – Anwar
    Aug 29 '16 at 13:13
0

For some unknown reason (may be running evince with root) some file's permission has been changed.

You need to execute these command to return back the ownership and the permission -

sudo chown sanjeev:sanjeev ~/.local/share/gvfs-metadata/home
sudo chmod 600 ~/.local/share/gvfs-metadata/home

That should fix the problem.

5
  • thank you very much it worked. when I open it in terminal and saw the error I pretty much knew what had happened. The thought never occurred to me. Again thank you very much Anwar. It was bugging me for quite a long time and I even started using Okular but I always liked Evince more.
    – gabs1bb3
    Aug 29 '16 at 13:20
  • @gabs.1BB3 Glad it helped :)
    – Anwar
    Aug 29 '16 at 13:21
  • I hit this page in a web search. I'm experiencing the same problem (Linux version 4.8.0-41-generic (buildd@lgw01-18) (gcc version 6.2.0 20161005 (Ubuntu 6.2.0-5ubuntu12) ) #44-Ubuntu). The directory is owned by me and I can create files via the shell, but evince reports an error with permissions. evince is not itself setuid and I can think of no reason why it should have no access. Any suggestions? May 8 '17 at 21:28
  • @FredDouglis have you tried the suggestion?
    – Anwar
    May 9 '17 at 6:05
  • My permissions were already set that way. May 9 '17 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.