0

This question already has an answer here:

Over the past week or so, I've been trying to create a bootable USB on Xubuntu for Windows. It seems like everything has more or less been unsuccessful, with varying degrees of success.

Using the dd command doesn't make the .ISO file bootable on the usb, and UNetBootin isn't able to create windows bootable USBs. I've tried to run Wine to run Rufus, a program that creates bootable USBs on Windows, but it was unable to find my USB while it was mounted. I've tried CrossOver to install a multitude of ISO burning programs, but none have worked so far. I'm at the end of my rope, and I'm wondering if there's anything else I should be doing or something I may have missed.

I am running Xubuntu 16.04 LTS.

marked as duplicate by karel, LiveWireBT, Mitch Aug 25 '16 at 8:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • The Windows images boot just fine with UEFI, the problem is to boot in legacy mode. I recommend Cornelius' answer (in the Q&A karel linked to) understand and configure a bootloader for MBR on the USB storage. – LiveWireBT Aug 25 '16 at 7:40
0

If you are using dd and the USB device is not booting, it means that the .iso file is not a hybrid file. You have to convert it to a hybrid .iso before you create your bootable USB device with dd. I haven't used this method for creating Windows bootable USB's yet but it works with all Linux isos I've tried so far.

  1. Make sure the iso you've downloaded is ok using a checksum file.

  2. Install syslinux-utils on your system by typing sudo apt-get install syslinux-utils.

  3. If you want to keep the original iso intact, make a copy and process the copy by typing isohybrid /path_to_copy.iso.

  4. After that, the copy's checksum test will fail and this is the sign that isohybrid has altered it so that it can create bootable USB devices too.

  5. Type dd if=altered.iso of=/dev/sdX bs=4M (where X is your USB device letter).

You should be able to boot your system with your USB device after this. I'll be waiting to see if this works with Windows isos too.

Not the answer you're looking for? Browse other questions tagged or ask your own question.