1

After reinstalling my NFS server S (Ubuntu 14.04.5 server which stores the home directory) and client A (Kubuntu 14.04.4 desktop) suddenly Firefox and Thunderbird complain about not being able to find their profiles: "Your firefox profile cannot be loaded. It may be missing or inaccessable."

Concerning Firefox, I checked file permissions, profile.ini, cache locations without succes. I eventually deleted ~/.mozilla to enforce the creation of a new profile, but still get the same error. Obviously, the problem is not introduced by any file from ~/.mozilla.

Firefox and Thunderbird work perfectly on a different NFS client machine B (Kubuntu) which accesses the same NFS server S, using the same directory. I conclude that the problem is created by the machine, not the home dir. On the other hand, a different user can start Firefox without problems even on client A.

Has anybody any idea what could have caused this weird problem?

1

Using strace firefox revealed that for some (still unknown) reason Firefox tried to locate the directory /var/cache/${USER}/.kde/mozilla/firefox which did not exist. Creating /var/cache/${USER} with proper ownership and permissions 750 helped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.