0

Thanks for the interest.

I removed my ODD and changed for a aluminium caddy with a 2.5 SSD. In other word, removed the DVD reader for the laptop in exchange it got a HDD case.

I haven't found the way to mount it, the first try was to format and since then GpartEd returns me errors. Suppose to be FAT32

sudo fdisk -l

returns:

Disk /dev/sdb: 119.2 GiB, 128035676160 bytes, 250069680 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xc8b6fe4c
Device     Boot Start       End   Sectors   Size Id Type
/dev/sdb1        2048 250069679 250067632 119.2G  b W95 FAT32**

But when I try to mount, I get this:

mano@mano-Lx:~$ sudo mount /deb/sdb /mnt
mount: special device /deb/sdb does not exist
mano@mano-Lx:~$ sudo mount /deb/sdb1 /mnt
mount: special device /deb/sdb1 does not exist**

It doesn't matter if the partition is Ext4, NTFS or FAT. There is no way to mount. I don't know if is because it is connected where there should be a CD player.

Let me know what is in your mind. Thanks in advance.

EDIT according to answer

sudo mkdir /mnt/sdb1
sudo mount /dev/sdb1 /mnt/sdb1

mount: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error

In some cases useful info is found in syslog - try dmesg | tail or so.

dmesg | tail

[23976.434536] ata3.00: status: { DRDY ERR }

[23976.434541] ata3.00: error: { IDNF }

[23976.448321] ata3.00: configured for UDMA/133

[23976.448363] sd 2:0:0:0: [sdb] tag#23 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE

[23976.448370] sd 2:0:0:0: [sdb] tag#23 Sense Key : Illegal Request [current] [descriptor]

[23976.448376] sd 2:0:0:0: [sdb] tag#23 Add. Sense: Logical block address out of range

[23976.448383] sd 2:0:0:0: [sdb] tag#23 CDB: Read(10) 28 00 0e e7 c2 00 00 00 08 00

[23976.448387] blk_update_request: I/O error, dev sdb, sector 250069504

[23976.448395] Buffer I/O error on dev sdb1, logical block 31258432, async page read

[23976.448421] ata3: EH complete

2

You wrote /deb instead of /dev. Try

sudo mkdir /mnt/sdb1
sudo mount /dev/sdb1 /mnt/sdb1

You should then be able to see your files in /mnt/sdb1, for example in Nautilus or via

ls -la /mnt/sdb1
  • Oh those pesky typos – Elder Geek Aug 24 '16 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.