0

I installed ubuntu 16.04 alongside windows 8. Secure boot disabled, CSM boot mode in order to boot from usb. After booting from usb several times, i can not even get access to ubuntu. Windows does not recognize usb or usb installer. I fixed this problem by changing usb installer whenever got stuck.

Ubuntu installed fine on partition dev/sda9. I tried grub2win to boot, but it fails. For ubuntu black screen appears. Windows boots normally.

Also tried boot repair without success.

Main problem is that Ubuntu does not boot. Due to usb installer issue and dummy toshiba UEFI system I have limited access to ubuntu with usb drive only.

I appreciate your help in advance

  • 2
    You have to boot USB drive in UEFI mode to install in UEFI mode. help.ubuntu.com/community/UEFI and: askubuntu.com/questions/221835/… You may be able to boot Ubuntu if you go into UEFI and turn off UEFI. But with Windows in UEFI mode you may have to change settings everytime you want to reboot into other system. Better to have Ubuntu in UEFI boot mode. Issues common by brand, so even though different model: askubuntu.com/questions/597052/… – oldfred Aug 24 '16 at 20:01
  • Check that your BIOS/firmware version is updated to at least 6.60. Early versions of that machine had problems with earlier versions. – ubfan1 Aug 24 '16 at 21:59
-1

Maybe your windows is constantly setting up secure boot because you are not using the windows-in-built feature that lets you access the BIOS. I strongly recommend you to enable LEGACY support in your laptop if you want to try another linux distros or just install ubuntu, you can enable it in your BIOS settings too.

To access BIOS go to your windows 8, swipe left of the screen and go to

Change your Settings >> Update and Backup >> Backup >> Advanced startup >> Fix problems >> Advanced Settings >> BIOS/UEFI Config.

Then acces the BIOS and disable the secure boot, another thing is that Windows in EFI mode is the lord of the computer, and the only way to boot a pendrive is:

  1. In BIOS changing the order of boot
  2. Access to the pendrive/CD using an alternate key

the alternate key to boot device is not the same for each laptop, you can try with F1-F12 and is only available when the manufacturer logo appears, you can boot Ubuntu with this key too so is very important to know what key is, In my laptop is F12.

that will solve your problem...

If you want to use GRUB as your default bootloader, boot a live session with ubuntu in EFI/UEFI mode, open a terminal then type this.

sudo grub-install /dev/sda
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.