All started with some maintenance on a local Ubuntu server (14.04) we're using to handle our Jenkins builds. After attempting to update I get the following error:

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-3.13.0-91-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-extra-3.13.0-91-generic (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

So I run the command df -h to see whats going on:

Filesystem      Size  Used Avail Use% Mounted on
udev            3.8G  8.0K  3.8G   1% /dev
tmpfs           768M  716K  767M   1% /run
/dev/dm-0       227G  8.7G  207G   5% /
none            4.0K     0  4.0K   0% /sys/fs/cgroup
none            5.0M     0  5.0M   0% /run/lock
none            3.8G     0  3.8G   0% /run/shm
none            100M     0  100M   0% /run/user
/dev/sda1       236M  233M     0 100% /boot

Does this really say the entirety of my Ubuntu server is on a 236 Mb partition of a 250 Gb HD?!

So my first question is, did I really do that lol?

I appreciate the suggestions of other posts of a similar nature, however I have space on the HD, just no the partition; and I already tried the suggestion in the other posts.

If that is the case, is there a way I can allocate some of the other 249.75 GB of HD space to the Ubuntu instance?

Any other suggestions would be appreciated, but the ultimate goal is to either allocate the server a crap ton more HD space or BU (don't want to loose Jenkin's configurations) and rebuild/restore proper.

* EDIT 1 *

Based on a suggestion I ran the command lsblk and got these results:

NAME                             MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda                                8:0    0 238.5G  0 disk
├─sda1                             8:1    0   243M  0 part /boot
├─sda2                             8:2    0     1K  0 part
└─sda5                             8:5    0 238.2G  0 part
  ├─arc--build--vg-root (dm-0)   252:0    0 230.5G  0 lvm  /
  └─arc--build--vg-swap_1 (dm-1) 252:1    0   7.7G  0 lvm  [SWAP]

Which still makes me believe my primary boot partition is woefully undersized... :(


  • Respectfully I would assert this is not a duplicate simply because I've run out of space on the partition, not the HD itself. My assumption here being I can re-allocate space from the over 200 GB available. I also tried the top posters suggestion without any luck lol. Aug 24, 2016 at 17:15
  • check layout via: lsblk
    – TiloBunt
    Aug 24, 2016 at 20:12

1 Answer 1


cleanup old kernels

sudo apt-get autoclean
sudo apt-get autoremove

or expand the /boot partion

  • 1
    It's helpful if you actually explain how to expand the boot partition (at least an on-site link). Otherwise, don't include it. Aug 24, 2016 at 21:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .