3

I have checked the following instructions, but none of them helps me (and I don't have sufficient reputation to comment on them):

  • Xubuntu doesn't lock screen anymore
  • Keyboard shortcut for Lockscreen not working

Situation is:

  • If I press Ctrl-Alt-L or Windows-L the screensaver gets enabled but it doesn't lock the screen.
  • Earlier I used Logout command which has locking command as a side feature, but the locking options seems to have been removed.
  • If I go to All Settings --> Brightness & Lock, the Lock is grayed out but the option Require my password when waking from suspend is on. So I guess that is only from suspend and doesn't change screensaver settings.
  • If I give command gnome-screensaver, it says that there is one running already.
  • I gave command sudo apt-get install xscreensaver xfce4-session, and if I type xflock4 it now uses xscreensaver instead gnome-screensaver and follows its settings and locks the screen. But naturally I don't want to type this command every time I wish to lock the screen.
  • I installed xfce4-power-manager and executed xfce4-power-manager-settings, but how do I enable it (xfce4-power-manager and xfce4-power-manager --restart didn't do it)?
  • I have been unable to do any custom shortcuts: they all become disabled and I am unable to enable them.
  • I haven't tried if rebooting would enable one of the several trials I have done.
  • Did you change the login manager recently? If so, changing it back will do the job. Else, I have no idea. – Ceda EI Aug 24 '16 at 14:49
0

I got it working.

I believe this fixed it:

sudo apt-get upgrade ubuntu-core-launcher

For some reason the core launcher didn't upgrade with everything else and was somehow out of sync with the rest of the OS.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.