4

I'm running Ubuntu 16.04 with Google Chrome 52.0.2743.116 (64-bit) installed.

When I click on a file in the download section (chrome://downloads/), Chrome seems not to use my systems default application to open the file. It always picks other applications.

If I click on "show in folder", Chrome opens Audacious.

Also I set JavaWS from JDK 8 as my default to open *.jnlp files but Chrome always uses JavaWS from JDK 6.

Other applications like Firefox use the right applications.

Is there something Chrome specific that I need to change as well, when I do changes at my default Applications?

  • 1
    Did you try to reset the auto-opening settings? It's at Settings > Show advanced settings > Clear auto-opening settings. – Panagiotis Tabakis Aug 24 '16 at 13:07
  • I don't see the "Clear auto-opening settings" Button in the settings. Maybe it was removed... – Lars Aug 24 '16 at 13:45
  • 1
    I'm running Chromium Version 51.0.2704.79 Ubuntu 16.04 and It is on the Downloads section. Is your system fully updated? sudo apt update && sudo apt upgrade – Panagiotis Tabakis Aug 24 '16 at 13:47
  • I'm running 52.0.2743.116 (64-bit) – Lars Aug 24 '16 at 13:52
  • 1
    It should be a button under location select for Downloads. – Panagiotis Tabakis Aug 24 '16 at 13:57
4

I found out that Chrome uses xdg-open to open files.

I tried to open a file with xdg-open in the commandline. Which opened the same applications as Chrome did. So I viewed the output of xdg-open and found out, that xdg-open called gvfs-open, which was not installed on my system.

After installing it with sudo apt-get install gvfs-bin xdg-open (and Chrome) uses the right applications to open my files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.