I have a Seagate Freeagent external hard drive. While I was backing it up on Windows XP my pc crashed and I received the horrifying "Delayed Write Error" when I rebooted citing "$MFT" and a few other files. I tried to unmount it, but to no avail. Now my pc just crashes when I try to access it via Windows.

In Ubuntu I am able to view it through disk utility. SMART status is "DISK FAILURE IMMINENT". Fdisk doesn't work, and the SMART tests fail on "Reallocated Sector Count".

Is there any way for me to rescue any of my data. I can still access the drive but as soon as I do that it crashes.

  • Do you mean Ubuntu also crashes when trying to access the drive?
    – Sergey
    Nov 22, 2011 at 10:06
  • No, Ubuntu does not crash, but it is unable to access the files on the drive.
    – backitup
    Nov 22, 2011 at 10:22
  • The drive itself crashes when I try to access any of the files on it, but Ubuntu still recognizes it so it seems to be mounted.
    – backitup
    Nov 22, 2011 at 10:42
  • 1
    By "drive itself crashes" do you mean you're getting read errors whenever you try to copy files from the drive? I mean, a HDD is a physical object, not a program, it can't crash in the sense "unexpectedly terminate", only in the sense "violently collide with another object" :)
    – Sergey
    Nov 22, 2011 at 11:02
  • I'm getting read errors whenever I try to access the drive. It causes fdisk to hang. And when I try to open/access it the error is something like this "Error mounting: mount exited with exit code 13: $MFTMirr does not match $MFT (record 0). Failed to mount '/dev/sdb1': Input/output error", although it doesn't always complain about $MFT, sometimes other files.
    – backitup
    Nov 22, 2011 at 11:48

3 Answers 3


Your approach to use ddrescue is a good one. If the problem is caused by defects on platters surface, you should be able to rescue at least the un-damaged areas. Running ddrescue multiple times on the same output file will add new "rescued" data to that file - after some time you'll recover the most of what can be recovered. I'm sure you already read general overview and the the manual

If ddrescue fails immediately without recovering any data, regardless of which area of the drive you're trying to access, it suggests a failure of electronic components rather than the platters. What I would do in this case:

  • let the drive to rest. I used to have a drive which was starting to produce errors a few minutes after powered up; the longer it rested - the longer it worked. I left it "in a cool dry place" for a few months which allowed me to take a full snapshot without any errors - it worked several hours!.

  • take the drive out of enclosure and plug it directly via SATA. Just in case.

  • if you have another drive of the same model you can try swapping the electronic parts from the healthy drive - this is sorta risky as you can ruin both drives but I heard of people doing this with good results.

There are also some forensic methods using million-dollar equipment... but it depends on how valuable the data is.


Can't seem to log back in as "backitup", witness the noobness.

I did solve the problem. ddrescue is now in my mind the single greatest backup and recovery tool the world currently possesses. I must add, that on my work machine I received many errors during backup. When I took it home, it worked like a dream, a 14 hour dream but a dream nonetheless.

Bought a new internal, mounted the .iso file, et viola.


have you try photorec? If you can mount it, maybe...

  • No I haven't yet, but I have heard of it and as far as I know its only for photos(which is fine if that's all I can get). Some people say that it makes a bit of a mess. I'm trying to do a ddrescue so I have an image of the hard drive first, but this isn't working...
    – backitup
    Nov 22, 2011 at 12:43
  • 2
    It's not just for photos. As Wikipedia says (delinkified): PhotoRec is a file carver data recovery software tool designed to recover lost files from digital camera memory (CompactFlash, Memory Stick, Secure Digital, SmartMedia, Microdrive, MMC, USB flash drives etc.), hard disks and CD-ROMs. It recovers most common photo formats, including JPEG, and also recovers audio files including MP3, document formats such as OpenDocument, Microsoft Office, PDF and HTML, and archive formats including ZIP. Nov 23, 2011 at 3:02
  • You don't need to mount the drive to use photorec. The whole point of photorec is that it is filesystem-agnostic and accesses the raw data on the device.
    – landroni
    Feb 1, 2014 at 9:39

Not the answer you're looking for? Browse other questions tagged .