2

This is driving me nuts - I can't figure out how to disable autoupdates! In 15.10 I could turn off auto updates and I'd only get a notification if I had manually done a sudo apt-get update without actually upgrading, or it might tell me to restart after I've done a sudo apt-get dist-upgrade if it warranted a restart - both of which were still annoying.

In 16.04 I have the same settings, but I keep getting notifications out of the blue that I have software to update. I'm often tethering from my phone with a metered data plan and don't want it to be checking for updates in the background, nor do I want it to pop up notifications at random times - I'm usually pretty good about manually updating.

Here are my settings in the Software & Updates app: enter image description here

Ideally I could turn off the "Display immediately" and "Display every two weeks" options as well, but regardless it shouldn't be checking for updates at all, based on the "Never" option.

I've also gone as far as modifying /etc/cron.daily/apt-compat and /etc/cron.daily.aptitude to put an exit 0 at the top so they shouldn't be running anything.

My /etc/apt/apt.conf.d/10periodic file looks like this:

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::AutocleanInterval "0";

Edit

Now I'm just taking stabs in the dark:

  • I've added an exit 0 at the top of /usr/lib/update-notifier/update-motd-updates-available
  • I commented out the "${distro_id}:${distro_codename}-security" line under Unattended-Upgrade::Allowed-Origins in the /etc/apt/apt.conf.d/50unattended-upgrades file.

Hopefully one of those changes will cause it to leave me alone...only time will tell.

Edit, Part Deux

A day later, after making those other changes, I got yet another notification...so that didn't really seem to help. I'm really stumped and I don't understand why the built-in settings don't do anything.

1

try dconf editor. in gnome and gnome software setting part uncheck auto update.

  • Just to clarify - the closest I can find to what you describe is org > gnome > software > download-updates, which seems right. I just unchecked it, so we'll see if that fixes it. If there's another setting as well, could you please be more specific? Thanks – redbmk Aug 26 '16 at 12:55
  • Seems we're getting closer. After making that change I didn't get any updates for a while - almost two weeks. Then when I restarted one time I got a popup notifying me to update. There's also a setting com > ubuntu > update-notifier > regular-auto-launch-interval that was set to 14 days (the default is 7). It says that 0 will cause it to notify immediately. I tried changing it to -1 and we'll see what happens – redbmk Sep 7 '16 at 12:49
  • @redbmk did you found a good solution? btw askubuntu.com/questions/1112965/… – Aquarius Power Jan 26 at 1:38
  • I don't think I ever did, but I haven't used Ubuntu in a while now so can't really test it out – redbmk Jan 27 at 9:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.