5

I am having severe troubles trying to install the correct driver for ubuntu 16.04, graphics card nvidia GT730.

Intially installing the 361 driver caused me to have a log in loop. I managed to get past that but then grub crashed. I ended up having to reinstall ubuntu and using boot repair in UEFI mode.

The system was working again until I tried to install the latest driver 367.44 through the terminal, I got taken back to a login loop. I managed to purge the drivers and was able to log in again but my current driver xserver nouveau causes my screen to freeze so I would like a way of installing nvidia 367.44 without any issues. Reading up on the Nvidia guide it says that nouveau must be disabled to prevent the kernels interfering with the new nvidia driver. So I have tried blacklisting nouveau but have created further problems.

Computer overview...

  • os: ubuntu 16.04
  • graphics card: Nvidia geforce GT730
  • processor: intel core i5-6400 CPU @ 2.70GHz x4
  • OS type: 64-bit

The latest steps I've taken:

  • created file /etc/modprobe.d/disable-nouveau.conf
  • blacklist nouveau
  • options nouveau modeset=0
  • reboot
  • Install nvidia 367.44 through terminal
  • sudo nvidia-xconfig

that didnt work so I tried adding:

  • blacklist nouveau
  • blacklist lbm-nouveau
  • options nouveau modeset=0
  • alias nouveau off
  • alias lbm-nouveau off

Followed by

  • echo options nouveau modeset=0 | sudo tee -a /etc/modprobe.d/nouveau-kms.conf
  • sudo service lightdm stop
  • sudo service gdm stop

Then I installed 367.44 through the terminal and it suggested I disable UEFI secure boot, which I did. And upon restarting I get stuck in a log in loop and removing the blacklist, purging the nvidia drivers and boot repair doesn't help.

Anyone have any ideas????

I feel like updating drivers should be such a standard thing but it's causing so many problems!

Any help would be extremely appreciated- I've had this issue for over a week now :(

Lisa

-------past post----------

I had a few problems with my screen freezing so I tried to install some drivers from the nvidia website but they didn't work. So I then tried changing the driver from system settings which has left me unable to even log into the computer. I have tried a number of things and nothing has worked so far.

Attempts:

  1. changed the driver from xserver to NVIDIA 361 - stuck in a log in loop.
  2. install gdm, install failed - black screen on login, if i press ctrl-alt-f1 I get the message: started job running hold until boot
    finishes" and I cant access the terminal unless i boot from USB or in recovery mode
  3. tried accessing gedit in /usr/share/X11/xorg.config to try edit the driver config - didn't work from a USB boot
  4. tried booting in recovery mode: sudo apt-get remove plymouth, sudo apt-get remove xserver-xorg-video-intel, but the screen stays black
  5. I've tried sudo apt-get purge nvidia-*, sudo add-apt-repository ppa:graphics-drivers/ppa, sudo apt-get update, sudo apt-get install nvidia-361/ xserver,
    but doing this in recovery mode does nothing because it isn' connected to theinternet.
  6. tried rebooting into GRUB, highlighting the Ubuntu option and editing, adding nouveau.modeset=0 on the end of the line - no response

I'm running out of ideas now. if anyone knows how to help I would greatly appreciate it!

Lisa

  • Have you installed your Nvidia driver? – Dante Aug 24 '16 at 11:20
  • @dante I had assumed it was already installed as the graphics card came with the pc. The cd was set up for windows, but I am downloading a linux graphics driver now. hopefully that will work. thanks – L Marfell Aug 24 '16 at 13:53
  • You don't need to install Nvidia driver manually. Do sudo ubuntu-drivers devices and install one of the drivers introduced, for example sudo apt-get install nvidia-361 – Dante Aug 24 '16 at 13:58
  • @dante thanks for your comment. On the drivers information on my PC I am given three options: 1. NVIDIA binary driver - version 361.42 (proprietary tested), 2. X. Org X server - Nouveau display driver (open source), 3. NVIDIA binary driver - version 340.96 (proprietary). The driver selected previously was the X. Org X. I will try the 361 and see if that works. Thank you! – L Marfell Aug 26 '16 at 7:41
  • I tried that and restarted the computer. I then got stuck in a log in loop. So I tried installing gdm , but that didn't work. then i tried sudo apt -get install nvidia-current and reboot but got a black screen. I've been told to boot linux from a usb to access the hard drive and change the driver through sudo gedit, but i'm not too familiar with linux. Do you know how to do this? Once booting through f2, do you know how to get to the command line? – L Marfell Aug 26 '16 at 8:58
1

From Nvidia customer service.... The following worked for me:

NVIDIA Driver Installation for Ubuntu 16.04

for Ubuntu 16.04, please try the following manual driver installation procedure:

  1. blacklist open source nouveau driver by the command

    sudo printf "blacklist nouveau\nblacklist lbm-nouveau" | sudo tee /etc/modprobe.d/blacklist-nouveau.conf 
    
    blacklist nouveau
    blacklist lbm-nouveaulisam@Atlas-PC:~$
    

to update the boot process run the command

    sudo update-initramfs -u 

    update-initramfs: generating /boot/initrd.img-4.4.0-36-generic
    W: Possible missing firmware /lib/firmware/i915/kbl_dmc_ver1.bin for module i915_bpo
    W: Possible missing firmware /lib/firmware/i915/skl_guc_ver6.bin for module i915_bpo

Reboot

  1. use ctrl+alt+F1 to go to a console, then login and use the command

    sudo service lightdm stop (command to exit the gui) 
    
  2. change directory to the Download folder where you usually download the NVIDIA driver

cd /home/usr/Downloads

run sudo sh and follow on screen instructions

    sudo sh ./NVIDIA-Linux-x86_64-367.44.run

It may say that the pre-installation script failed and do you want to continue and answer Yes.

    The target kernel has CONFIG_MODULE_SIG set, which means that it supports cryptographic signatures on kernel modules. On some systems, the kernel may refuse to load modules without a valid signature from a trusted key. This system also has UEFI Secure Boot enabled; many distributions enforce module signature verification on UEFI systems when Secure Boot is enabled. Would you like to sign the NVIDIA kernel module?

    <Install without signing>

I tried installing without installing and I get an error message saying I needed to sign the kernel module or signing was necessary for secure boot up.

I tried to disable secure boot:

plug in USB Restart and enter BIOS Advanced mode> secure boot Windows UEFI mode OS Save secure boot keys Select USB drive as file system Saved four key files PK, KEK, DB, DBX to USB Delete PK to disable secure boot Save and restart with Other OS type and Secure Boot state disabled

    WARNING: Unable to find a suitable destination to install 32-bit comptability libraries. Your system may not be set up for 32-bit compatibility. 32-bit compatibility files will not be installedl if you wish to install them, re-run the installation and set a valid directory with the –compat32-libdir option.
    <OK>

    Would you like to run the nvidia-xconfig utility to automatically update your X configuration file so that NVIDIA X driver will be used when you restart X? Any pre-existing X configuration file will be backed up
    <YES>
  1. reboot or run this command to start the gui:

    sudo service lightdm start
    

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.