3

The screen resolution of my monitor is 1920x1080 (since it could run at 1080p in Windows 7), but however it runs at 1024x768 in my Ubuntu 12.04.

The output for lspci | grep -i vga is

00:02.0 VGA compatible controller: Intel Corporation Device 1912 (rev 06)

and the output for lshw -C video is

  *-display UNCLAIMED     
   description: VGA compatible controller
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 06
   width: 64 bits
   clock: 33MHz
   capabilities: vga_controller bus_master cap_list
   configuration: latency=0
   resources: memory:f6000000-f6ffffff memory:e0000000-efffffff ioport:f000(size=64)

I have Ubuntu 12.04 running on the system. I have tried a variety of methods. I have tried using xrandr as given in Failed to get size of gamma for output default when trying to add new screen resolution and whn I try to set resolution in displays I get the following two error messages:

required virtual size does not fit available size: requested=(1920, 1080), minimum=(1024, 768), maximum=(1024, 768)
GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._gnome_2drr_2derror_2dquark.Code3: required virtual size does not fit available size: requested=(1920, 1080), minimum=(1024, 768), maximum=(1024, 768)

I tried debugging it but with no success.

I also came across that Intel has removed support for Ubuntu 12.04 and is that why I can't settle on any solution? I would like to try manually installing the drivers but I am clueless which one to go after.

I have also tried using nomodeset by updating the grub, but no use. Can anyone suggest something?

1

Are you using a VGA (blue din) cable, and is it a Samsung Monitor ? Try a DVI cable. This is common on Ubuntu derivatives (such as Zorin/Mint etc.). Are you using an nVidia driver ? Nomodeset can also work, have you tried Grub Customiser ? I am pretty sure it works by tweaking GRUB_GFXMODE.

2
  • I had tried both VGA and DVI cables with a Dell monitor and I wasn't using nVidia driver (which was also clear from output of lshw -C video ). I had probably naively tried nomodeset, and nothing worked. But tweaking GRUB_GFXMODE in grub file by executing gksu gedit /etc/default/grub, followed by sudo update-grub and rebooting solved my problem. However, on reboot I get the following error: CRTC 382: trying mode 1920x1080@77Hz with output at 1024x768@76Hz (pass 0). I tried with fail: github.com/dnschneid/crouton/issues/299
    – Saby
    Aug 24 '16 at 8:30
  • OK, maybe also look at askubuntu.com/a/681832/249734 but it involves code and you may have tried it when xrandr probing. It's awkward because you are basically re-applying the settings every boot from a script. As a somewhat costly solution, I'm running a GT710 half height card in the odd small form factor box with good results.
    – mckenzm
    Aug 24 '16 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.