2

I downloaded and installed the Tor browser bundle according to the offical instructions however, using the option --register-app after ./start-tor-browser.desktop to add it to the ~/.local/share/applications directory in order to be recognised by the menu.

The browser appears in the "Internet" applications tab, but I am unable to actually start it. I can launch the browser by accessing the directory in the terminal with cd and entering ./start-tor-browser.desktop and also by double-clicking the .desktop file in the unpacked folder, I can even create a symbolic link of that file, move it to any other location and launch the browser by double clicking that link file, but it just won't open from the whisker menu.

I even tried moving the symbolic link that works everywhere to the ~/.local/share/applications folder to make it appear in the whisker menu, which it does, but clicking it in the menu still does not launch the browser (double clicking it in the file manager does, however).

Is there any way to make this link work in the whisker menu? Or could I alter the command that gets executed so that it enters the directory in the terminal and calls ./start-tor-browser.desktop there?

At this moment, the command looks like this:

sh -c '"/home/tux/tor-browser/Browser/start-tor-browser" --detach || ([ ! -x "/home/tux/tor-browser/Browser/start-tor-browser" ] && "$(dirname "$*")"/Browser/start-tor-browser --detach)' dummy %k

Edit (solution): I may have found a way to solve this issue by random trial and error. I deleted the dummy %k from the command of the menu item without fully understanding its meaning and it launches reliably now. I am going to research what this actually does and if it's necessary, maybe someone with experience in terminal commands could also chime in.

  • Have you tried running the command 'sh -c..." from the command line? Were there any error messages? Please add results to your question, if applicable. – Kevin Bowen Aug 23 '16 at 23:33
  • Hi Kevin, I just tried running the command in the terminal and it worked. It just doesn't work when called from the menu somehow. – Prototype700 Aug 23 '16 at 23:42
2

I just tried in Xubuntu 16.04.

All I did was execute

./start-tor-browser.desktop --register-app

And it worked like a charm. It shows up in Whisker Menu.

If you go to ~/.local/share/applications and open Tor Browser with Mousepad or any other text editor, make sure Exec looks like this

Exec=sh -c
'"/home/caligaris/Downloads/tor-browser_en-US/Browser/start-tor-browser" --detach
|| ([ ! -x "/home/caligaris/Downloads/tor-browser_en-US/Browser/start-tor-browser"
] && "$(dirname "$*")"/Browser/start-tor-browser --detach)' dummy %k
  • Hi, my problem was not that it didn't show up in the Whisker menu at all, the --register-app option reliably made it appear in the Internet tab. My problem was that I was unable to actually start it from the menu, only double-clicking the file in the folder would work. Were you able to just launch it from the menu? As can be read in the question, the command looks identical. I may however have found a solution for my issue and edited my initial question. – Prototype700 Aug 24 '16 at 10:26
  • I was able to launch it from the menu, I had no problem. – Giovanni Caligaris Aug 24 '16 at 12:52
  • Hmm.. strange, k. – Prototype700 Aug 24 '16 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.