3

Thanks for reading.

I've had ubuntu 14.04 for years, and bumblebee with nvidia-304 worked pretty fine. Now i'm switching to 16.04 and i've found that I cant run bumblebee with the nvidia-304 driver (My graphic card is listed on nvidia-340, but working terrible, like 1 fps on glxgears and all stuff).

Here's my conf files and lspci.

All ideas are welcome:

lspci | grep 'NVIDIA'

02:00.0 3D controller: NVIDIA Corporation GT218M [GeForce 315M] (rev ff)

bumblebee.conf

# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
[bumblebeed]
# The secondary Xorg server DISPLAY number
VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name)
ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)
Driver=nvidia
# Directory with a dummy config file to pass as a -configdir to secondary X
XorgConfDir=/etc/bumblebee/xorg.conf.d

## Client options. Will take effect on the next optirun executed.
[optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus.
Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?
AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia
[driver-nvidia]
# Module name to load, defaults to Driver if empty or unset
#KernelDriver=nvidia-current
KernelDriver=nvidia-304
PMMethod=auto
# colon-separated path to the nvidia libraries
#LibraryPath=/usr/lib/nvidia-current:/usr/lib32/nvidia-current
LibraryPath=/usr/lib/nvidia-304:/usr/lib32/nvidia-304
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path
XorgModulePath=/usr/lib/nvidia-304/xorg,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau
[driver-nouveau]
KernelDriver=nouveau
PMMethod=auto
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

xorg.conf.nvidia

Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "false"
    Option      "AutoAddGPU" "false"
EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"

#   If the X server does not automatically detect your VGA device,
#   you can manually set it here.
#   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
#   as you see in the commented example.
#   This Setting may be needed in some platforms with more than one
#   nvidia card, which may confuse the proprietary driver (e.g.,
#   trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
    BusID "PCI:02:00:0"

#   Setting ProbeAllGpus to false prevents the new proprietary driver
#   instance spawned to try to control the integrated graphics card,
#   which is already being managed outside bumblebee.
#   This option doesn't hurt and it is required on platforms running
#   more than one nvidia graphics card with the proprietary driver.
#   (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
#   If this option is not set, the new Xorg may blacken the screen and
#   render it unusable (unless you have some way to run killall Xorg).
    Option "ProbeAllGpus" "false"

    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "UseDisplayDevice" "none"
EndSection

dpkg --get-selections | grep 'nvidia'

bumblebee-nvidia                install
nvidia-304                  install
nvidia-current                  install
nvidia-opencl-icd-304               install
nvidia-settings                 install

optirun -vvv firefox

[  839.149086] [DEBUG]Reading file: /etc/bumblebee/bumblebee.conf
[  839.149371] [INFO]Configured driver: nvidia
[  839.149553] [DEBUG]optirun version 3.2.1 starting...
[  839.149571] [DEBUG]Active configuration:
[  839.149575] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[  839.149580] [DEBUG] X display: :8
[  839.149585] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia-304:/usr/lib32/nvidia-304
[  839.149589] [DEBUG] Socket path: /var/run/bumblebee.socket
[  839.149595] [DEBUG] Accel/display bridge: auto
[  839.149599] [DEBUG] VGL Compression: proxy
[  839.149603] [DEBUG] VGLrun extra options: 
[  839.149608] [DEBUG] Primus LD Path: /usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus
[  839.164089] [DEBUG]Using auto-detected bridge primus
[  839.853294] [INFO]Response: No - error: [XORG] (EE) 

[  839.853326] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) 

[  839.853368] [DEBUG]Socket closed.
[  839.853401] [ERROR]Aborting because fallback start is disabled.
[  839.853410] [DEBUG]Killing all remaining processes.
  • I know it's not really much of help, but I hit the same issue and after couple of attempts in different setups with different versions of nvidia drivers I gave up. Especially after noticing that bumblebee project seems dead now? No updates since 2013. New version of ubuntu apparently brought changes that bumblebee isn't too compatible with. – Jacek Aug 24 '16 at 15:32
  • Just commenting that I have the same issue. I'm using nvidia-340 (which was working on this computer with Kubuntu 14.04), and I have very similar output from optirun -vvv. I find it strange that the Xorg error is just an empty string: [XORG] (EE) – Supernormal Feb 23 '17 at 16:22
  • I am having the same problem, in switched to nvidea-375 and it worked. But then when I rebooted it did not login with lightdm and after trying a lot of things I had to fall back to 304 that still do not work. – alexmogavero Oct 21 '17 at 12:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.